Critical resend ratio

Hello all,
I am new to 3D printing, I have a Creality ender 3 Pro with bl Touch installed.
motherboard 4.2.2 and Bios Merlin 1.1.2 from 2020.4.25.
I have Octoprint Version 1.5.2 installed from "octopi-buster-lite-0.17.0" on a 4 GB Raspberry pi 4.
The prints go perfectly well through the micro SD.
On the other hand as soon as I go through Octoprint I have this message displayed:

Critical resend ratio!
16% of transmitted lines have triggered resend requests. The communication with the printer is unreliable and this will cause print artefacts and failures.

Please see this FAQ entry on tips on how to solve this.

and it results in the printing of blockages, and large stain of material

What should I do to correct this problem?

Thanks in advance for any help!
Sincerely Pierre

Try a different USB cable. It is likely that there is some interference or general problems with the transmission over USB.

Try at least 2, if not 3. Aim for thicker cables. Read the FAQ article that the notification mentions?

I have tried several of different types and the message still appears.
I took the opportunity to try the OctoPi Release Candidate 0.18.0rc2 version, the message arrives later but the printer systematically fails

Make sure there are no other devices interfering, the cable is not folded, the printer's USB port is working properly.

I did read of a hack, to connect the ground pin of the Pi to the ground of the frame of the printer, something someone linked on a Creality forum.

This may not help you but I had the same problem occurred only when connected OctoRemote and Octoprint in my browser at the same time with the webcam running. So I would assume it is bandwidth issue i.e. my Raspberry Pi 3B+ cannot server to clients and the printer at the same time.

I had the same problem with my Ender 3 Pro and Raspberry pi, always around 15% resend and all prints were failing. I was using a 2 prongs power supply with a Raspberry pi connected to the 4.2.2 board.

The hack proposed by Charlie_Powell fixed my problem, but you don't have to run a cable from the Pi to printer. I just connected the shield of the micro USB connector to the chassis of the Ender 2 Pro and everything is OK now: Resend ratio: 0 / 208.3K (0%).

Maybe using a 3 prongs power supply for the Pi can fix this problem, but I haven't try this one.