CTC Replicator Clone - Using x3g Files


What is the problem?
Hi , I have a CTC Dual, (replicator 1 clone) running sailfish 7.7. Octoprint sees and communicates to the printer, and i have GPX 2.6.2, I have two problems
1 Uploading G-Code to ocotprint and getting it to convert to x3g on the fly, sends the printer "crazy" print head slams to one side, and keeps trying.
2 If i upload the x3g file directly to the SD card, Ocotprint errors, and looses communication to the printer.

What did you already try to solve it?
I have tried multiple files, i have tried creating g-code in makerbot and cura - no difference. If i upload the x3g file from my laptop and then use octoprint to start the printing, it works fine

Running latest version of octoprint and octopi, terminal screen shows the below

Send: M28 /screen.x3g
Unexpected error while writing to serial port: IOError: 'Command not supported or recognized' @ comm.py:_do_send_without_checksum:3005
Changing monitoring state from "Operational" to "Offline (Error: IOError: 'Command not supported or recognized' @ comm.py:_do_send_without_checksum:3005)"
Connection closed, closing down monitor





I have the same printer, and have experienced many of the same problems.

You can fix the crazy behaviour on uploading G-code to the GPX plug-in by changing some G-code header data. I will find my Cura profile and the settings I have (I now have it all working smoothly and well).

I also had a very similar communications problem and that (bizarrely) turned out to be broken wires to the X-axis stepper. The think that clued me in to this was a stutter in motion when both axes were moving. (you need X to be moving to see the problem, and in my case the problem was only evident at certain Y positions as the wires flexed in the bundle)

Please help me! Offline: IOError: '[Errno 5]

Glad it's not just me... If you could let me have your cura profile that would be a great help, and i'll check all my cables as well




I can't upload a Cura .3mf file to this forum.
So I put the file on Github.

I can't figure out if it is possible to export the Octopi printer profile as a file too. You might need that to get the X3g to generate correctly. Until I work out a way to export that, I have put up a set of screen grabs with what is working for me.


Great, thanks I'll give it a try over the weekend and I'll let you know


Thanks for all your help, working brilliantly:grinning:


It would be useful if you explained what the differences are, since not everyone uses Cura. I've been trying to fix similar issues with another Replicator clone and it's better, but still problematic. It would be nice to be able to replicate whatever you changed :wink: