Please help me! Offline: IOError: '[Errno 5]


Had to replace the main board. After that my first test print with Octo print stops at the beginning of the first layer and then I get this error. Any ideas? Never seen this before.

I'll add that this printer has been running for 3 years, all I did was change out the main board. I see this issue could be power to the Pi, but nothing changed there...

UPDATE: I have rebuilt Octoprint with a new Pi3 with built in wifi. I have changed out the USB from the Pi to the printer with multiple different USB cables. I have changed out the cable and the power supply to the Pi. I tried an amazon fireTV 9w brick, all my apple bricks up to the 12w iPad brick. I tried a regular 12v USB power supply. I have tried everything I can think of.

Only thing I feel like it could be, is this new boards firmware is not compatible with octoprint? Can someone post the latest working sailfish firmware.

I would really love some help here, I have things to print for my wedding and cant get them done. :frowning:

I can get versions and firmware when I'm home later.


Maybe the last board had a different firmware. Can we get the output of the Terminal?

You might want to read my notes from here:


This is what terminal outputs when the failure occurs. I'm not sure what you wanted me to look at in your notes, but that is all just regular setup info for octoprint. I have had this set up for years. Am I missing something?
Also Sailfish version is 7.8 r0f02f

Recv: okSend: N12 G1 Z5*84Recv: okSend: N13 G28 Z F500*8Recv:  T:42 /0 B:47 /60 T0:42 /0 T1:48 /200 @:0 B@:0Recv: okSend: N14 M132 X Y Z*109Recv:  T:42 /0 B:48 /60 T0:42 /0 T1:51 /200 @:0 B@:0Recv: okSend: N15 G1 X110 Y-72 Z30 F3300*26Recv: okSend: N16 T1*12Recv: okSend: N17 M116*19Recv:  T:54 /200 B:50 /60 T0:42 /0 T1:54 /200 @:0 B@:0Unexpected error while reading serial port, please consult octoprint.log for details: IOError: '[Errno 5] Input/output error' @ monitoring state from "Printing" to "Offline (Error: IOError: '[Errno 5] Input/output error' @"Connection closed, closing down monitor


Just flipped the printer over, checked all connections and then tried to reprint again, and this time got this.

Send: N56 G1 X27.134 Y34.914 E12.66362109Recv: okSend: N57 G1 X25.000 Y35.357 E12.72833110Recv: okSend: N58 G1 X-25.000 Y35.357 E14.21289*71Recv: T:200 /200 B:61 /60 T0:86 /0 T1:200 /200 @:0 B@:0Unexpected error while writing to serial port: IOError: '[Errno 5] Input/output error' @ monitoring state from "Printing" to "Offline (Error: IOError: '[Errno 5] Input/output error' @"Connection closed, closing down monitor

Bolded text is different from the previous error.


I have also tried a new Pi power supply sold with the last Pi kit I bought a few months ago, and no luck.

@markwal You always have the answers!!! Any ideas on this one?!?!?


In the Notes section, I personally had to toggle off the checksum in my config.yaml.


I saw that but have no clue what that means. Whats the config.yaml?


By remoting into the Raspberry, you can edit files. In this case we're interested in OctoPrint's config.yaml.

ssh pi@octopi.local # default password = "raspberry"
nano ~/.octoprint/config.yaml



Oh, so I add that line in that section.


Alright, well I added that line in there. And no Go, Same error. :frowning:


Is this a FFCP or a clone? I had a bunch of these sorts of issues with one of my QIDIs, and I had to basically get rid of my printer profile and recreate it to get things working again. GPX printers can be very painful with OctoPrint, though flashing Marlin or swapping boards for an MKS with Marlin or Smoothie has been known to make life easier without buying a new printer.


This is a real FFCP.


Please someone help me.


I have one of these FlashForge Creator Pro printers at work. My own printer at home is a slightly-forked Marlin on a Robo 3D with all their other software stripped out.

Many suggest that the FlashForge isn't all that compatible with OctoPrint. Since I'm bull-headed, I did a fair bit of work trying to get that to connect at work, bringing a Raspberry Pi 3B with me. You saw the data from the table in the compatible printer table and that's what I did to get it to connect. Apologies that I didn't run an M115 to discover the firmware version but I'll try to do that next week around Wednesday when I eventually go back to work.


Try RepRap flavor instead of MakerBot flavor GPX...SF 7.8 is RepRap flavor.


Well, it looked like one of the errors happened after a T1 (switch to left extruder), so that made me think perhaps the wrong printer profile was selected in GPX settings: try MakerBot Replicator 1 Dual. But really the error I expect there is that it complains about not having another heater or something like that.\

The part you quoted out above had the error happen shortly after just a regular move command so that suggests a communication failure, but you've taken a bunch of the normal steps you'd take to reduce that: good power supply, short USB cable with a ferrite choke. The stepper motor cables generate a lot of RF noise that can interfere with the serial over USB communication. You can sometimes change that by attempting to keep the USB cable at right angles to the runs of stepper cables and as far away from them as practical. I wonder if there's something about the new board that makes it noisier.

BTW, what version of Sailfish does the new board have? Where did you get it?


Firmware is, Sailfish version is 7.8 r0f02f. Got the board from FlashforgeUSA.

The printer is doing some other binding and weird stuff since the board replacement as well. FF support is telling me that the X Motor cable was damaged in the swap of the board, which I highly doubt because I was very careful. But going to look again to see if I see any physical damage. But it sounds like that resistance or problem with the cable, if there is one, could cause this communication issue?


Well I made my own cable for the X motor and seems that this has fixed all my problems. Crazy that some cheap broken copper would cause all these issues. I should have known after going through all the upgrades on the Monoprice select mini where the bed heating wires break within the first 100 prints for sure!

Anyway, thanks for your help!



Sorry, I missed this. I could have saved you some trouble, as I had exactly
the same problem with exactly the same root cause.

It seems I mentioned it in passing, but not in a way that would show up in
a search.