Cura lost ability to print directly to Octoprint?

What is the problem?

I'm really not sure what is going on . I wanted to print something and for some reason when I slice it says save to disk instead of the usual print to Octoprint

What did you already try to solve it?

I've tried to go into printer profile to re connect to server but the option that says connect to Octoprint is missing? What am I missing here ? The only thing I've recently done was installed some Plugins for Octoprint i.e. PrintTime Genuis the UI update and Dashboard etc.. Why would cura lose the ability to even give me the option of connecting the section where one would enter the API key ?

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Ender 3 No > Latest OctoPrint/PI , Cura 5.5

I've just installed the latest version 5.6 of cura and it's still doing the same. Why would it lose the tab that allows you to connect to a printer ? Something strange going on.......

Do you still have the OctoPrint connection plugin in Cura, and is it enabled & working?

Found the issue not to worry....

Yes that was the problem. I performed a system restore from 2 weeks ago and it must have been before I setup my PI .. thanks ..

1 Like

Ops.. more issues.. when I click on Print with Octoprint it now says Waiting for Octoprint to connect to the printer but it is connected? Any ideas ? Sorry to be a pest

I had the same issue, when I had an instance of Octoprint already running.
I resolved this by shutting down Octoprint restarted Cura and then went into Connect dialog box to find that Cura had lost the API key. Once I had re-established this, Cura worked normally.

I found this happened after I updated Cura to latest version.

1 Like