CURA monitor issues for 1 of 2 printers

What is the problem?

In CURA Monitor screen for ONE of 2 Octoprint connected printers:
Temperatures do not update
Progress doesn't display
Abort and Pause greyed out.

I have been using Octoprint for years with my original printer which is a HICTOP printer that never came with any predefined profiles in CURA or Octoprint so it was all self defined. I slice in CURA, send to Octoprint, CURA switches to Monitor screen, I watch both bed and hotend temps rise, jub starts, I can monitor progress, pause, abort. All good.

Two days ago I bought a Creality CR-10 printer. Created a new printer profile in Octoprint for it. Activated it. Created a new printer in CURA (it is a model with a CURA profile predefined), connected it to Octoprint, printed... Printing works fine. I have ipOnConnect and Octotext lugins installed and those work fine, i.e. I get notified when a job finishes and CR-10 display shows IP address when Octoprint connects to the printer.

But when I have the Creality CR-10 activated in Octoprint and selected in CURA in the CURA Monitor screen the temps never update, they stay at the start temp. I do not get a progress indicator or time estimates. I cannot pause o abort the job. Octoprint is the only active button in Monitor.

My HICTOP printer is using Marlin firmware and the Creality is using Marlin/Creality 1.1.6 firmware.

I am guessing this is a firmware thing but I just wanted to make sure I wasn't missing something stupid in a setting somewhere.

Latest CURA (5.3.0) and latest Octoprint 1.8.7

What did you already try to solve it?

Tried to spot a difference between the two printers.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Not tried because one printer works

Systeminfo Bundle

[|attachment](upload:// (1.8 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Further update... no longer thinking this is related to the firmware version on the printer... When I go to the Monitor screen in CURA and click the link to Octoprint and log into my Octoprint server the temperature graph accurately displays the changes in temperature that the printer is reporting... so this has to somehow be related to how CURA is talking to Octoprint via the Octoprint connection. I have Octoprint Connection 3.7.3 installed in CURA.

So for sure it comes down to what am I missing... works when talking to the same Octoprint server with my old printer is the starred profile in Octoprint and Acitvated in CURA but not when I have the Creality profile starred in Octoprint and Activated in CURA...

OK, I have it working... maybe now that I know the workaround I cna find the cause and solution...

I switched my Creality printer API key from an Application Key to the Octoprint Global API Key and everything seems to work...

And when I look at my old HICTOP printer... which does have an Application Key listed in Octoprint... thats NOT what it uses in CURA... it uses my Global API Key in CURA

So it would seem that CURA Octoprint Connection has issues when using Application Keys vs Global API Key...

That's not the ideal way to have it - the global API key is going to be removed, albeit there is no set date for that yet. If you have issues with application keys vs. global key, you might want to report it as an issue on the Cura plugin. Or perhaps @fieldOfView can provide some insight here, maybe as to which logs etc. to look in to troubleshoot the connection.

Yup. You are spot on. just reposted on the Octoprint github issues page.

I am looking in to it on the github issue queue

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.