Cura octoprint connection lost after octopi update

What is the problem?

Octoprint Plugin option missing after I sliced I only had the option to "save file". Figured it must have had something to do with me reflashing octopi. Couldn't find Octoprint connection option under "Manage printer" in Cura. So I uninstalled plugin and tried again twice without luck.

What did you already try to solve it?

I tried to reinstall the Octoprint plugin. Twice.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

octopi 0.18.0
octoprint 1.5.3
Cura 4.8.0

Of course you can ask this question here - but if no one answers I would suggest you try it in the Ultimaker / Cura forums.
On which OS are you running cura?

Maybe @fieldOfView got an idea.

Windows 10

I'm the creator of the Cura OctoPrint Connection plugin.

As you know, for diagnosing OctoPrint problems, we need to see octoprint.log. So it is somewhat logical that to diagnose Cura problems, we need to see cura.log. It can be found in the configuration folder in Cura, which can be accessed via Help -> Show configuration folder. Please upload the cura.log file somewhere (dropbox. google drive, etc) and post a link here.

Ok. Here is the file. I called it MacDee_cura.log

It looks as if when you wanted to uninstall the plugin to reinstall it, you disabled it instead. Go to the "Installed" tab of the Marketplace, and make sure the checkmark in front of the OctoPrint Connection plugin is checked, not unchecked.

1 Like

Thanks, that was it. I saw that it was showing as installed. I didn't know it had to be checked to be active.