Cura OctoPrint Connection plugin

Thanks a lot sir, worked like a champ.

Thanks! that worked!

@fieldOfView, I'm having trouble with Cura 4.8 and updating OctoPrint Connection. I had 3.5.17 installed but the Marketplace claimed there was an update, however, clicking the Update button did nothing. I tried the Uninstall button and that worked but after closing and restarting Cura, I can't find the OctoPrint Connection in the list of plugins. I see on github that the current version is 3.5.18.


Try downloading the release from the github and drag it into cura like an stl. That should install it.

@b-morgan, are you by any chance logged in to an Ultimaker account in Cura? In that case, try logging out.

It could be that you are being marked as a Cura Essentials user. Essentials is a program where customers pay for the privilege of getting fewer features. And it works by email domain name, so if someone who has an email address with the same domain as you signs you pays for Cura Essentials then you also get the "benefits" of that. I am as stumped as you are about how that works.

If all that doesn't work, you can download the 3.5.18 release and drop the file onto the buildplate in Cura as if you were opening a 3d model.

@jneilliii, I don't publish releases on github for my Cura plugins. I should, but I still have not set that up.

Off topic but: W.T.F. :flushed:

1 Like

Logging out and logging in fixed it. Thanks :sweat_smile:

1 Like

Hello and good day, My issue with the plug in is that it does not recognize octoprint anymore. it was working great but then stopped. cura no longer can see my printer on my network, no more easily sending files to the printer after slicing and no more monitoring prints from cura.. very sad time around here with out these wonderful features. for reference on what i've done to troubleshoot, i uninstalled cura and reinstalled. uninstalled the plugin and reinstalled it, after that didn't work i used the link provided above and after removing the plugin again i dragged the file into cura restarted it and the plugin still doesn't recognize octoprint. your help would be greatly appreciated

have you tried manually entering the ip address to connect to octoprint?

ie, setup the connection manually like you've never connected before.

I had not retried this option as i was used to it showing up automatically. after entering the local ip it was able to let me get the api key back. thank you for your help

What is the problem?

I note that Ultimaker Cure has the ability to link with Octopi. But I am not sure how to do this. I would be grateful for help with this. At the moment from I design with Tinkercad, .. download the stl to my Downloads.. then pick the design up with Ultimaker and save the code to an appropriate folder. I then set Octopi running and from that upload the code and follow procedure to print. This works well but any shortcuts would be welcome.

What did you already try to solve it?

Just looked at Ultimaker without doing anything for fear of corrupting print quality.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)



Additional information about your setup

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.3 Safari/605.1.15
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3966898176
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2
printer.firmware: Marlin Creality 3D


The Cura OctoPrint Connection plugin by @fieldOfView pretty much just automates these exact steps, nothing more, nothing less.

1 Like

To elaborate on what @foosel already said, the OctoPrint Connection plugin can be downloaded via the Marketplace inside Cura (for free and without needing an Ultimaker account). After installing it and restarting Cura, you go to the "Printers" pane of the preferences and press the "Connect to OctoPrint" button to open the dialog that lets you connect your printer as you have set it up in Cura to your printer in OctoPrint.

That's not entirely true. It also auto powers on printers (with appropriate power related plugin), waits for printtimegenius analysis (if installed), uploads thumbnails (with my Cura Thumbnail plugin installed in OctoPrint), auto starts the print. It literally is one button printing for me.

1 Like

I have started experiencing a really frustrating issue with the octoPrint plugin in Cura. It seems to get stuck at "Waiting for OctoPrint to complete Gcode analysis…" step. It will not proceed unless I tell it to Print now. Has anyone else dealt with a similar issue?

Do you use the Print Time Genius plugin?

Yes, I do have the Print Time Genius plugin intalled.

Print Time Genius needs time to analyse the gcode file. If you start the print while Print Time Genius is still analysing, then it will stop analysing so the resources that would be used for analysis will not affect the print. So the choice is to either wait, or disable Print Time Genius.

My Cura and Octoprint weren't this slow with the print time genius plugin until I changed my mainboard to the SKR mini.

I don't see how a different printer PCB would affect how long Print Time Genius takes. I think it is more about previous versions of my plugin just ignoring the fact that Print Time Genius needs time to process the file and thus negating the functionality of that plugin. I'll see about making the waiting for the plugin to do its thing optional.