Cura OctoPrint Connection plugin


I am the author/maintainer of the OctoPrint Connection plugin for Cura, which lets you print directly from Cura and monitor the progress from within Cura, all without creating and uploading gcode files manually:

I realize this is not strictly an OctoPrint plugin, but figured it would be helpful to users of this forum to give their feedback here instead of having to create an Ultimaker or Github account.

So, if you have questions or suggestions about the integration between Cura (the desktop application, not the CuraEngine slicer) and OctoPrint, let me know.


I'd just tried the plugin on my Linux Mint Machine with latest cura 3.4.1-ppa but i can't install the plugin, neither via the (User) Plugin Directory nor via apt. The letter one says that the package "cura-plugin-octoprint" can not be found.

I've added the Repository as usual, no error message. Octoprint runs with Version 1.3.9 . It would be a pleasure for me & others to use the plugin, so, what next?



I don't think the ppa is maintained anymore. It was never an official distribution of Cura. It is recommended to use the appimage instead.

The plugin is distributed via the "Toolbox" in Cura 3.4, or "Marketplace" in Cura 3.6.


Works. One happy user more in the world :slight_smile:



Hi @ttrueten!

never mind - was a mishap of me...


@mods: This is not a solution to the OP. The OP wasn't a question, but an invitation to discuss/ask questions.


Ooops - should read the whole thread :blush:


A new version of the plugin, which adds support for the App Keys in OctoPrint 1.3.10 and fixes a couple of bugs that crept into the 3.5 version, is now available via the Marketplace (previously Toolbox) in Cura.


Not sure if it is the plugin or Cura but I have never been able to print to a busy printer. The plugin or Cura reports the printer is busy. There have been occasions when I was able to send a print to the cue but the print never showed up. It is not a show stopper but I am only commenting because you asked for comments.
I have not tried to print to a busy printer recently so can't give more details but if this is something that could be looked at I can provide full details.


Do you have the "Store G-code on the printer SD card" option enabled? That would require pushing the file over the same USB connection that is being used by the printing.


Sorry about the delay in answering ...
Where would I find this option?


In the Connect to OctoPrint dialog from the Printers pane of the Cura preferences.


Ahhh, got it, not checked.
I will have to double check things though because I also did not select
to "show webcam image" and that has always displayed;
Some experimenting is in order!




The camera showing even if it is not selected was a bug that has been fixed a little while ago. Please check if there's an updated version of the plugin in the Marketplace/Toolbox.


I upgraded to the latest version. When I try to print a model in Cura while the printer is busy, I now get 'CONFLICT' reported.
Thinking about this some more, it would appear to me that cueing a print while octoprint is busy might not make much sense since the new print might well run into the print that is still on the build surface (unless it waits for the operator to clear the build surface)
I get "octoprint is busy, unable to start a new job". When I click on 'cue job' octoprint returns a 'CONFLICT' error although the interface seems to have saved the print job on the pi.
Where on the pi would the print file be stored ? I don't have a microSD card in the printer so maybe it is complaining about that ?
It did not print the supposedly saved file.


When you "queue" the file from Cura, it should appear as a file in the sidebar, but it will not start printing automatically. You would have to start the print from the OctoPrint interface after the current print has finished (but you can still monitor its progress from Cura). If you have suggestions how to change the language to better explain this, let me know.

The "CONFLICT" state happens when you try to upload a file with the same filename (jobname in Cura) as the currently printing file. Normally OctoPrint (silently) overwrites the file on upload, but it can't (and won't) do this if it is currently printing the file that you try to overwrite. Could this be what is happening? If not, please open an issue at and add your cura.log (from the Configuration folder in Cura, see Help -> Show Configuration folder)

I think that the plugin should do a better job at explaining the "CONFLICT", but I had not yet encountered it in the wild and hence have not come around to adding that.


That explains that ... yes, I used the same model and put it in several
different positions on the build plate to test things out.
Suggestions to better explain the "CONFLICT" would be to replace it with
"Can't cue file with same name as file currently printing" or better
yet, when it is determined that the same file is being attempted to be
printed, rename it with a '-x' consequential number like what happens in
many operations in Linux.

Thanks for all your help, I would have been lost without it !


I'm unclear if this the best place to provide feedback on the Cura OctoPrint plugin? Or is Github issues the preferred forum?

I'm trying to connect Cura 2 printers but the Cura Printer profile seems to use the save OctoPrint settings for both my printers. I'm using Cura 3.6 and the latest Octoprint plugin. Happy to provide more details here or else where...



This feedback topic is here for simple questions and feedback and for people that don't have and don't want a github account.

Yours seems to be a setup-specific issue that may require some back-and-forth between us, so I would suggest you open a github issue if it is all the same to you.


Will there be support for Cura 4.0 beta?