Cura OctoPrint Connection plugin


#22

Yes there will.

There was a bit of an oversight in Cura 4 beta 1 and the plugin marketplace where it was not possible to publish a plugin for both 3.6 and 4.0. So I have to wait until Cura 4 beta 2 is released until I can publish an update.


#23

Because the release of Cura 4.0 beta 2 still has not been released, I have worked around the issue mentioned above, and created a version of the plugin that is compatible with Cura 4.0 beta 1 (and should still work with beta 2 and beyond).

http://files.fieldofview.com/cura/OctoPrintPlugin-v6.0.0-2019-01-28T16_19_16Z.curapackage

Download the file, then drop it into a running Cura application and restart Cura.


#24

This seems to be an amazing feature, but I cannot get it to work on both Cura 3.6 and 4.0. Did someone face an issue with the API key?

I just copy the key from octoprint into cura, but it does not work. Error message: "The API key is not valid. You can get the API key through the Octoprint web page."

Cheers,

Gabriel


#25

Are you sure you are entering the whole API key, and nothing but the API key (no leading/trailing spaces). Have you tried the "Request" button in the Connect to OctoPrint dialog?


#26

Yes, I verified that I am copying the whole (and only) the API key. I assume the problem could be related to my reverse proxy since I am using haproxy. I will disable it and try again.

Which request button? I don't see it.

Thanks for your reply.


#27

It should run fine through haproxy, if haproxy is properly configured.

Could you post your cura.log (found via Help -> Show configuration folder) somewhere (dropbox, google drive, wetransfer, pastebin.com, ...) and give me a link? I'ld like to see if the plugin is doing something unexpected.


#28

The request button worked :wink: The API key cura got using the request button is not the same as the one I was copying from the octoprint settings. I don't know why, but I am glad it works now.

Very nice tool :wink: Thanks!


#29

With the "Request" button you get an Application Key. They are new in OctoPrint 1.3.10, and conceived to give you more finegrained control over which applications can access your OctoPrint instance (as well as making the copy/paste thing less prone to issues).

You can revoke access to Cura, without changing your API key (which would also revoke access to all other applications that use the API key)
See https://docs.octoprint.org/en/master/bundledplugins/appkeys.html


#30

BETA 2 is available, does it work now?


#31

There is now a version of the plugin in the Marketplace that will work with both Cura 3.5, Cura 3.6 and Cura 4 beta 2 (but NOT with Cura 4 beta 1).


#32

Hi!

Thank you for your plugin, I really enjoy it!!

Is there a way to add a camera source select?
When I switch to "Monitor" tab, the main camera linked to octoprint is automatically selected, but I have two and I don't see a way to switch between them.
I've modified octoprint (mjpg stream, locally + multicam plugin) to load two cameras on the same raspberry pi I use to print; the only place I can choose between the streams is throug OctoPrint webpage, it would be super handy if I could choose from the Cura application.

Thank you!
Dario.


#33

Not with the current release of the plugin. Do you use a particular plugin to switch between cameras in OctoPrint?


#34

Yes, I use MultiCam (0.2.6).


#35

Cura has released V.4 . Is the beta connection plugin still working with that?


#36

The version that is currently in the Marketplace should be compatible with Cura 4.0. Let me know if it isn't.


#37

Hi, where in Cura 4.0 does the “print with OctoPrint” button appear? I have the plugin ofc


#38

You first have to connect the printer you have configured in Cura to the OctoPrint instance that controls the physical printer. See the “Connect to OctoPrint” button on the Printers pane of the Preferences.


#39

So far, I'm not able to get the plugin to work. I pasted the API from OctoPrint, but it's calling it invalid. I saw you mention a "Request" button above, but I don't see anything like that


#40

What version of OctoPrint do you use? The Request button will only show up if you use OctoPrint 1.3.10 (or newer) and have the AppKeys plugin enabled (which is the default).

On the API tab of the preferences in OctoPrint, is the "Enable" box ticked?


#41

The marketplace version is working just fine with me for the non-beta 4.0 just released, however I did have some trouble initially and ended up having to completely delete the OctoPrintPlugin directory in my plugins folder before reinstalling the marketplace version. Just using the function within Cura to uninstall the plugin didn't seem to work and I was going around in loops with the 3.5.4 version of the plugin showing as installed but could never actually enable it in Cura. Anyway, hope maybe this helps somebody. If you're having trouble make sure the old legacy files are gone, gone, gone! :slight_smile: