Cura OctoPrint Connection plugin

Thanks for letting me know there is a possible issue when upgrading the plugin. I must admit that I don't often install/upgrade the plugin myself because I run Cura from a development environment. I'll try to look in to this soon.

Seem to have the exact same problem. API key not being recognized with the newest version of Cura (4.0.0) and Octoprint 1.3.10.I'm using Connect to OctoPrint" version 3.5.4.

Could you go to "Help -> Show configuration folder" in Cura, and zip up cura.log, packages.json, plugins.json and the plugins folder, then post the zip somewhere so I can have a look?

Thanks, I got the files. Unfortunately, cura.log was not included. Could you post that too?

Yes, here is link:

According to the cura.log, both OctoPrint instances are rejecting the entered API key as invalid (it returns a 401 status code). Is there no "Request" button next to the API key field? With the "Request" button, you will not have to copy/paste an API key manually:

Does your OctoPrint instance respond to the following:[the same API key you entered in Cura]

No, I dont see any area to request a key. this is what I see:

When I follow the link you provide with my API key I get a Text output in my browser window.

...and that text output would be...?

I cut off the top part that included my API key for security reasons

That would be a successful (JSON) dump of your settings and the use of the correct API key in this case. You might want to just enter that API key into the dialog box in Cura.

I mean, that's the key that I tried to put in Connect To Octoprint but I still get this error:

Is it possible to change the port to 5000?

Not sure what to tell you. Have you tried the other entities on the left?

A prerelease version of the OctoPrint Plugin for the newly released Cura 4.1 beta can be dowloaded here:

Please drop the downloaded file into a running Cura application window, and restart Cura.

Unless issues are reported with this version of the plugin, it should be available as an update on the Marketplace soon.

1 Like

So I've not used OctoPrint for a couple weeks. It splashed "There is an update". Having not had issues before, i thought sure!

  1. I noticed I could only upload gcode files. Is the Cura 18.04.4 engine gone?

2 my primary workstation is an HPmini110 - i686 processor...aka 32 bit. 18.0.6 is the only 32bit version of cura available. I'm running Lubuntu 18.06.

3 I have other 64 bit "machines" but only raspberry pi's. I found this Plugin for Slicers, how do I connect it. I have Cura 18.0.6 installed, Blender, Slicr, Slicr for Prusha, FreeCAD, LibreCad, K-3d.

I found plugins that allow me to upload .stl files, but then the slicer plugin won't load my file, I haven't figured it out?

I seem lost in time, in just 3 weeks!!!

I think most of us slice with a stand-alone slicer outside of OctoPrint and then upload the gcode file. You'll find that you'll enjoy really great control over what options you have as well as a slicer that's years newer.

The blog entry for the latest version talks about the Cura engine, btw.


Thanks for your plugin, it is really a wonder to work with comfort, a plugin essential for me.

1 Like

Please note that this thread is about a plugin for the standalone Cura version to send sliced gcode to OctoPrint. Not about the CuraEngine plugin that can be integrated into OctoPrint. Read the OctoPrint blog entry about this new version of OctoPrint, which no longer bundles the CuraEngine.

That's a rather old version. Ultimaker stopped supporting 32 bit systems after Cura 2.1 (in 2016). Perhaps you can compile things from source, but that's not a straightforward endeavor. Note that the plugin that this thread is about will only run in Cura 2.3 or newer.

I don't think anybody has managed to compile all the required bits to run Ultimaker Cura on a Raspberry Pi yet. I would say it does not have enough memory to run both a desktop and a memory-intensive process like a modern slicer.

1 Like

It would be great to be able to configure the ip of the camera directly from the plugin in Cura. So it would not be necessary to open the Octoprint web interface. Thanks.

Thanks for the suggestion, but I do not plan to reimplement configuration of OctoPrint into the Cura interface. The Cura plugin gets whatever URL and orientation for the camera stream is configured in OctoPrint from the OctoPrint instance.