Cura OctoPrint Connection plugin

And if you are using OctoPi (which you haven't specified but is the most common form) it'll have to be 80 because 5000 is not open on the network.

In general I'd advise you @roland78 to be a bit more forthcoming about your setup here because right now it's pretty much impossible to help you considering that we no pretty much nothing but "can't connect from Cura". To what version. How installed. On which kind of network setup. Etc etc. Information. We need it.

[REDACTED screenshot with public IP address] where to see this certificare? i just take it the address from IVP4 and put it here.
i installed all this octoprint from here On the blog: "OctoPrint around the World" (December 2016), foosel.
here was given this 3344 https://github.com/VMaxx/RepetierIntegration/issues/30 .i don't know is the solution from there is applicable to me or others.

so looks like when is start from the shortcut :

here is this :

This confuses me more than it answers questions. The "OctoPrint around the World" link does not contain installation instructions. The RepetierIntegration link is not about OctoPrint at all. The external IP address (86.120.xxx.xxx) is irrelevant, and it is not the greatest of ideas to post your IP address like that if you don't know what you are doing.

From your other screenshots, I gather that you are running OctoPrint on Windows, correct? In that case, do try 5000 as the port in Cura and uncheck the "use https" checkbox. If you run Cura and OctoPrint on the same computer, you can also try 127.0.0.1 as the address for the OctoPrint instance in Cura.

i run Cura and Octoprint on the same laptop,windows. fossel do it that instalation on windows step by step , and i do it too. what else can i say.somewhere i have something between cura and octoprint. i give a try .

Ok. Forget anything you read about the RepetierIntegration plugin for Cura. Repetier Host is a different printer host server. By default it runs on port 3344 (without HTTPS!). OctoPrint runs on port 5000 by default (again: without HTTPS!). Someone named VMaxx took my plugin to connect Cura to OctoPrint and changed it to connect to Repetier Host. That is why there is a lot of shared terminology. But there are important differences too, so blindly following "solutions" for that other plugin will probably not work for this plugin.

Unless you installed and configured a "reverse proxy" and an "ssl certicifate", do not select the "use https" checkbox.

1 Like

from there i do it and try it. to delete all this octoprint and reinstall from where you will telling me?
how long takes this cheking the API key? 1,2,3 or more minutes?

There is no need to reinstall anything just yet.

First try opening the web interface in your browser on http://192.168.1.6:5000 and tell me if that works. If it doesn't, then your problem is not with the OctoPrint connection plugin in Cura, but with installing OctoPrint.

i log it in. is working. the log in i do it few minutes ago in chrome too, now i'm on ophera.

there are updates marlin and i updated but the server not started automaticlly, and said i must restart manually.

Ok. Now, in Cura, in the Connect to OctoPrint dialog, select the "octoprint" instance you added and press "Edit". Change the port to 5000. If the advanced proxy settings are not showing, check that checkbox and make sure that the checkbox "Use HTTPS" is NOT checked. Press OK, and now try pasting the API key again.

i find it that box where was hiding. i unchecked. there was a REQUEST... and in log in. i try it with your nr.127.0.0.1:5000 and i'm log in. this means is working? to try with my IP address too?
o yes and CURA REQUESTED ACCESS ,....

Don't let me stop you...

127.0.0.1 is always the ip address of the computer you are directly working on. So of I try to connect to 127.0.0.1, that is the computer I am typing on now. If you connect to 127.0.0.1, that is your laptop. The 127.0.0.1 address only works because you have Cura and OctoPrint on the same computer. The address 192.168.1.6 can be used by any computer on your network to connect to your laptop.

Anyway, it seems like your problem is solved.

i see.
OF COURSE MY FRIEND, THE PROBLEM IS SOLVED. THANKS.

So... what did we learn:

  • There are all kinds of (good and bad) tutorials on the Internet
  • Some work for what we're doing, some don't
  • The author of the plugin probably is the real expert here
  • Repetier Host and OctoPrint are different software and use different ports
  • HTTP and HTTPS are different, the latter requires you to setup a certificate
  • If you're running everything on the same box then the 127.0.0.1 IP address is the best way to connect
  • When someone asks you for the logs, they probably need those to help you

So I have been using octoprint with Cura successfully for a while now and it randomly stopped connecting the other day. Octoprint through a browser works fine but in Cura it does not connect. When I go to printers>connect octoprint it shows zero instances to choose from. I have restarted everything a couple of times as I have found that to work before but no luck now. Cura is 4.3.0, octoprint and your plugin are both up to date as of today. Octoprint is on a PI3b+, Cura is on a win10 machine, and both are hard wired to my network. Not sure how to troubleshoot this further. Any ideas??

Auto discovery issues are hard to track down. Have you tried adding a manual instance (using the "Add" button in the Connect to OctoPrint dialog)? You can use either the ip address or the hostname if name resolution (eg octopi.local or just octopi) works on the computer running Cura.

2 Likes

That worked, thanks!

1 Like

Hello, Great plugin. very handy, However since Cura 4.3 I get an Octoprint error: forbidden, in Cura
Have reinstalled Octoprint, Cura and the adding and still get the same.

I cant seem to see what causing this. Any help please

James