Cura OctoPrint Connection plugin

Is OctoPrint working normally? Can you save a gcode file from Cura and upload it?

Is OctoPrint printing when you get the "forbidden" error? If you are printing a file, you can not overwrite it.

Can you upload your cura.log file somewhere (eg pastebin, or dropbox) and post a link to it here? See Help->Show configuration folder

I have found the problem to be the automatic configuration file in the addons. I created an new profile in the addon and entered the API code manually and all now is well. Using the auto generated file the API code was not being recognized even when using the request button. it was reporting it as invalid.

I am now working again.


To celebrate the plugin crossing the 200.000 download count, you can now sponsor my work on the Cura OctoPrint Connection plugin through Github Sponsors, or through Paypal. The plugin is and will always be free to use, but your support is appreciated.

1 Like

Feature Request: Would it be possible to configure a folder into which the uploaded print will be stored? We have multiple people in the household uploading prints and the root folder gets very cluttered. It would be nice to allow each client to specify a default upload folder.

I just want to say thanks. I had setup Octopi this past weekend, and have been using it for a few days when I found this plugin in the Marketplace. I was expecting it to be simple - upload the print and nothing else - or kludgy. But it's not - it's feature rich enough that I don't need to switch to the Octoprint Web at all. Setup and printing also worked perfect the first time with zero issues. I am very impressed, and very happy. I feel like my hackable cheap Ender 3 is now comparable or better than high end printers that have proprietary printer software with networked printing, and all it cost me was a Raspberry Pi and webcam I already had sitting around.


Thank you for your kind words. For a half a year or so the OctoPrint Connection plugin was developed side-by-side with the Ultimaker 3 network functionality. For a while the only thing the OctoPrint connection plugin didn’t have that the UM3 did was automatic filament detection and selection. Since then, the two have diverged a bit, but I think the OctoPrint Connection plugin has the better featureset :wink:

Yes, this would certainly be possible. The trickiest bit is adding an interface for it. It would be annoying for many workflows if this folder would be configured in the "Connect to OctoPrint" dialog; I would prefer it to be near the jobname in the main viewport area, but that is harder to get at / extend.


Testers needed

I'm working on support for the following plugins for automatically turning the printer on when uploading a print: TP-Link Smartplug, Orvibo S20, Wemo Switch, Tuya Smartplug, Domoticz, MyStrom Switch, Tasmota and Tasmota MQTT (along with PSUControl, which was already supported). If one of these plugins is detected, the Connect to OctoPrint dialog will have an option to "Automatically turn on the printer" using a configured plug. After sending the API command, the plugin will wait until the printer is connected to OctoPrint and continue uploading the file.

Here's a development snapshot of the plugin: CuraPackage for Cura 4.4.x. Download the file, and drop it into the running Cura application window (not into a folder!). Then restart Cura.

The above version also includes (hopefully) better discovery and better handing of timeouts and refused connections when checking the API key.

Edit: I have updated the link above.

1 Like


Thanks for the efforts.

I've just tried the snapshot with cura 4.4.1 and OctoPrint 1.3.12 running on OctoPi 0.17.0.

HAProxy is enabled by default (on OctoPi), but configured for SSL only on 443. OctoPrint is running on localhost:5000 on the rpi. I'm using private CA, and imported in both relevant systems.

I can connect to interface of ssl with browser (win/lin client -> octopi/print)
I can execute api call from external machine.

Unfortunately I can't connect with OctoPrint plugin. Logs are attached
I've "checked" the HAProxy + SSL options for the plugin, linked to the server declaration.

Any ideas? (4.7 KB)

Thanks for testing the development snapshot. Does the connection work with the stable version from the Marketplace?

The HTTPS handling does not get much testing, so it might very well be buggy. I'll try to look in to it.

Also see

With the marketplace version and https, the plugin "hangs" on testing the api key. In dev version this at least fails-fast.

I see this as an absolute win! :nauseated_face:

Seriously though, the stable version fails just as fast, but it does not show that to the user. I'll look in to it more.

This new development snapshot probably fixes the https issue. It also fixes a couple of issues with the power plug plugin support.


So can connect, and just started remote printing. Will "play" with it a bit further ...

Where can I find the log files to assist with any issues with my power plugins?

Octoprint logs? have you tried the added link to your post :wink: ?

In Cura, see Help -> Show configuration folder. The logfile is named cura.log.

No, the Cura logs.

Thanks. So far I've verified TPLink plugin is working as expected. What is the logic for sending the power on command? Does the Cura plugin just check to see if the printer is disconnected and if it is it sends the power on command and then waits for connection to printer? This process only happens if the auto-print option is enabled?

:+1: That's the only smart plug I have available for testing myself.

Yes, for now.

Good point. Currently, it happens regardless of the auto-print option, but it makes sense not to wake the printer if the auto-print option is not selected.

Just tried the Package you provided here and I do not get the Automatically turn on printer option in the connect Ocotprint Dialog.

I'm using the Tasmota-MQTT plugin v.35 (has turnon and turnoff api)

Are there any other conditions or plugins required to get the option to appear?