Cura OctoPrint Connection plugin

Sorry I had more screenshots in my answer but as a new user I am not allowd to load more than one:
this is how mine is looking and the little icon is missing

UltimakerFormat Package is installed and active

What platform do you run Cura on?

Can you post a link to a cura.log? It can be found in Cura via Help->Show Configuration Folder

Windows 10 Cura 4.5
cura.log (118.5 KB)

interesting tried to reproduce for the log and did the same procedure to upload a seccond fil.
now even if i take a different file cura tells me

You have selected the option to upload to the printer SD card. I recommend you don't. Could you try unselecting that option in the "Connect to OctoPrint" dialog?

Was your printer connected to OctoPrint when you tried uploading direct to SD-card?

Could you DM me the output of[your apikey] ? Edit: this is probably not necessary; see @jneilliii's point below.

The octoprint plugin shows a little refresh icon next to it, meaning you need to restart octoprint.

1 Like

Thanks for chiming in, I missed that (too).

Sorry my fault I unchecked the sd card and it uploads again without error

I missed the update icon, but cannot restart right now because a print is running ,
will do a restart/reboot tomorrow morning to see if fixed
Thank you so much for the important advises !

I'll see if there is anything I can do to improve the support for uploading to SD card. It will always be very slow to complete, but the dialog you got was probably incorrect and should be fixed.

no change rebooted the octopi to be sure, everything is loaded,
update icon is gone but still there is the little image button missing!


at least now I have a entery in the plugins section
but either switch on or off,

no small icon is shown.

But for my understanding this is the switch for the big preview right?

I tried independently the small icon not appearing to Implement the big icon in the list.:

Do I understand right that in themeify

I just add the rows like in described


or do I have to add manually in some files via putty ?

Sorry for these kind of questions but I am just getting into the stuff.

as always thank you in advance

The thumbnails don't magically appear for gcode files you uploaded previously. They will only appear for files that are uploaded as .ufp files. A .ufp file is - as I said before - a specially made file that contains both the gcode file and a thumbnail image.

Now that the Ultimaker Format Package plugin is properly installed on your OctoPrint instance, the Cura plugin should detect it and send .ufp files instead of .gcode files automatically. Upload new files, and the button to show the preview thumbnail should appear for that file.

There is nothing you have to do in Themify.

1 Like

Hello - I have 3 Pis with static IPs, but the plugin is selecting the same IP address for two different Pis and so one of them can not be connected to.

I have loved using thisplugin, so thank you for your work, but if I can understand how this workjs then I can get back to printing Visors for the local NHS!

Many thanks


Have you tried manually adding the pi's by IP address only versus using the name? Are you using the name for one of them?

1 Like

Can you post a link to your Cura.log file? It can be found via Help -> Show configuration folder in Cura.

How did you set up the different PIs? Did you create one working OctoPrint image and duplicate that? In that case, I can imagine that Cura thinks it is seeing double. It might work to just change the hostname for each of the instances (eg via ssh and raspi-config), or even to change the "title" in the OctoPrint Settings -> OctoPrint -> Appearance pane.

Another quick workaround is - as @jneilliii suggested to manually add the OctoPrint instances by their IP (or hostname, if name resolution works correctly).

Hi fieldOfView,

thank you so much for your work! That plugin is really a benefit for me.

I'm wondering why the estimated time to print differs from the time octoprint predicts.
Would it be possible to include the runtime and maybe a button to connect to octoprint in the plugin?
Oh and maybe the present layer.

Thanks again and keep up the good work


Thank you for coming back to me. All 3 pis were created using the Octoprint image, but all IPs, hostnames and Name on Octoprint have been indivualised.

I did try adding it by manual IP but it didn't work.

Having said that. I have just rebooted the Pi and it is now connected properly - but the other one has gone off line from Cura's point of view, even though it is printing!.

I am in the middle to two long prints on the other printers so i will shut everyhting down when finished, restart amd see what happens. If it recurs I will post the logs as requested.

Many thanks for all your work and help,


That should not be the case.

The OctoPrint plugin shares the sidebar with what USB printing shows in Cura, and that does not include the runtime. I can jump through some hoops and do an overhaul there, but that means more development and maintenance work (ie: higher chances of things breaking with future Cura versions).

What exactly do you mean by runtime? I assume how long it has been printing the current print job? The currently printing layer is hard to figure out precisely due to buffering.

Do you mean a button to open the OctoPrint web interface? I keep adding that, but it keeps disappearing somehow in newer versions of Cura. I'll give it another go.