Cura to Octoprint Shifting Support Structure Gcode Issue


#1

What is the problem?
I am slicing my file in Cura and putting it into Octoprint. In Cura the layers and supports are in the correct position, but when I look at the Gcode Viewer before I start the print, the support structure is shifted to the left a few mm. I tried to print it; and it was going well until it got to layer 7 (nothing is special about the layer) and it decided to print to the left a few mm. After printing that one shifted layer, it went back to normal (printing in the correct spot). I attached a photo comparing the two side by side.

(I am printing the main structure with Polylite PLA and the support with Polydissolve using the Lulzbot Dual Extruder v3)

Has anyone else had this issue or does anyone have any advice?
Thank you!

Tech: Lulzbot Taz 6, Dual Extruder v3, Raspberry Pi 3 B+, Octopi/Octoprint, SD Card


#2

Check to see if you have any post-processing scripts in Cura that could be (attempting to) modify the GCODE.

Try running OctoPrint in safe mode and pause during the first layer. Then use the Gcode Viewer to review that problematic layer to see if it will be good or not and decide to continue the print. If it's still projecting a shift like before, report back to us.


#3

I checked for post-processing scripts in Cura, and none were active.

I ran OctoPrint in safe mode and I am still having the same issue. After further analysis, it seems as though any print with (2) different filaments (using the Lulzbot Dual Extruder v3) is having the same issue. It is shifting one material over several mm on the x-axis. See attached screenshot from a different model. I am also going to attaching the Gcode for review. We are not having this issue when only printing with (1) material. Any help is greatly appreciated!

LTAZ6DV3_dualTest3a (1).gcode (148.4 KB)


#4

Looks like you have set a wrong nozzle offset for your multi extruder setup in OctoPrint. It cannot render stuff at the proper position if it doesn't know where that proper position is.


#5

Awe, man... you beat me to it!

(Make sure to mark her answer as fixing it.)


#6

The solution above worked. Cura automatically calibrated the system for the second hotend but Octoprint did not. 13mm on the X-axis fixed the issue. Thank y'all for all of the help!