Cura wont connect to Octoprint

What is the problem?

Cura wont connect to Octoprint

What did you already try to solve it?

Update internet settings

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I recently relocated my workshop and had to adjust my raspberry pi to see my new internet. Im running a Taz 5 on a Mac using Cura. I reinstalled the micro SD, and successful can get Octoprint to connect with and control my printer. However, Cura wont connect to Octoprint, Ive tried changing the API key, is there something I need to change on the raspberry?

You mention changing the API key, have you checked the IP address of the Pi has not changed? It's highly likely it has if you have a new connection.

It looks like the IP address hasnt changed on the Raspberry, but if it has, how do I change it in Cura?

I actually have 2 IP addresses associated with the Raspberry, and it looks to be correct in Cura.

Please be more specific. Always be as specific as you can. What do you do, which button do you press, what happens instead of what you expected to happen?

You may want to look at this issue:

If that looks familiar, then this comment has a development snapshot of the Cura OctoPrint connection plugin that works around the issue.