Customize default controls - Extrude feed rate range?


#1

The Control tab Tool buttons produce a feed rate that's too high for my extruder, even with the Flow Rate slider all the way down. Can the extruder rate controls be customized?

It looks like a possible workaround is to define a custom control via .octoprint/config.yaml (http://docs.octoprint.org/en/master/features/custom_controls.html).

Maybe the default controls are defined with a similar config file, but I don't know where to find it.


#2

The extruder rate is controlled by your printer settings:
change the value for "E" in
Settings -> Printer Profiles -> [your printer] -> edit -> Axes


#3

If you're going to adjust the extruder feedrate, you might want to spend some extra time calibrating it. It usually involves creating a pair of marks on white filament and then extruding 100mm or similar, comparing the extruded distance against reality. You'd then adjust the setting and repeat the testing until you got it to be more accurate than before.


#4

I got fooled by the slider at first too. The trick is that, after you set the slider, you have to click the "Flow Rate" button below it to activate that setting. Then it works just like you'd expect. The fan control slider works the same way


#5

Thanks for these ideas! After looking into them a bit*, let me try to ask a more specific question:

The Control > Tool > Extrude/Retract buttons generate commands like this (copied from Terminal):

Send: G91
Recv: ok P15 B4
Send: G1 E10 F300
Recv: ok P13 B4
Send: G90

I’d like to reduce the feedrate value, currently F300. Manual testing shows that F50 is better. So, the desired output is:

G91
G1 E10 F50
G90

Is there a way to modify the output generated by these buttons, in particular the feedrate value?

*_Tried the Flow Rate slider (after pushing the accompanying button, thank you @Spyder :slight_smile: ). It sends an M221 command, which changes the Extrude Factor. I think sending M221 S10 means that the extruder pushes through 10% of the material specified by the G1 command, but the feedrate looks the same to my eye.


#6

I think I answered exactly this in my previous post ...


#7

You sure did!
I recalled setting up that field, but crucially not the footnote: "This information is used for manual control via the "Control" tab. It does NOT influence already sliced files that you upload to OctoPrint!"
Thank you.