Default USB webcam setting

Logitech C920s

Timelapse not working

Was working, hosed up by Spaghetti Detective

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

**Octopi / Octoprint 1.3.12, RPI 3b

Long story short my time lapse settings were changed by me and I can't remember the orignal settings that works. /webcam/?action=stream works for streaming, /webcam/?action=snapshot does not. It used to say something along the lines of 127.0.0.0/ (have no idea) /?action=snapshot

Can someone tell me the default settings?

It might have been http://localhost:8080/?action=stream and http://localhost:8080/?action=snapshot.

The stream url is the (optionally relative) url that octoprint serves to the browser. So /webcam/?action=stream works there, because that’s what your browser uses. It should NOT use localhost, because that would point to the computer the browser runs on.

The snapshot url is a url used by the computer running OctoPrint, so you use localhost (or 127.0.0.1) here to point to itself. This needs to be an absolute url.

1 Like

Of course, of course... it's about perspective. Since the only thing that uses the snapshot is server-side, you use http://localhost:8080/?action=snapshot. But since the stream is fetched client-side from the user's perspective, that approach wouldn't work.