Desktop install didn't work -> No monitor output

What is the problem?

Octopi 0.18.0 RC1 on a Raspberry PI 4.

Ran desktop install script answered 'yes' at end to have it boot to desktop and rebooted. Now when it boots up I get a blank screen. Octopi/octoprint is running since I can log in via web browser from my other computer. But on the monitor i have plugged into the HDMI 0 (HDMI 1 doesnt output anything) just shows a blank screen with a single '_' at the top that doesn't even blink. There is no command line, no output on startup showing the pi boot messages, no nothin'. Just a blank screeen.

Like I said, octoprint is working so I'm not dead in the water, but I'd like to use the desktop.

What did you already try to solve it?

Tried both HDMI ports, one doesn't output anything and the other outputs blank screen with underscore character at top. Unplugged/plugged in monitor. Switched monitor inputs. restarted the PI several times.

Have you tried running in safe mode and if so did it solve the issue?

Not yet, just started a long print i don't want to interrupt. will do that when it is done.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Just started a long print. I'll add logs when it is done.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octopi 0.18.0 RC1 on a Raspberry PI 4.

64 or 32 bit?

Try to log in via ssh and run

sudo apt update

and then

sudo apt -y install raspberry-gui-mods

I am running 64 bit

The last command returns an error:

E: Unable to locate package raspberry-gui-mods

Another thread said to disable IPv6 so I have done that. i've re-run the update and the enable guid script again. neither shows any errors. Going into Raspi-config and setting it to boot into gui doesn't have any affect.

I suggest you backup your octoprint and start over with a fresh image.
It can be really difficult to find what went wrong and how to fix it.

You also could start fresh and do it the other way: download a raspbian desktop image and install octoprint yourself

You can also use the 32 bit image, since I am not sure if the GUI installation process has changed there - it is fully possible that it has, and old things are no longer compatible. Regardless, I recommend the 64 bit build since it is still based on a beta upstream image, it is not classed as 'stable' or anywhere near yet.

1 Like

I'll redo the install starting with os+desktop and add octoprint on top of that. -- fingers crossed

1 Like

have a look to /var/log/syslog on your Pi.
It's a text file you can read with almost every editor.

that was harder that I thought it would be. Ended up giving up halfway through because it wasn't working.

So I went back to testing OctoPi images and tried the 32bit RC1. That seems to have worked and I'm able to install the desktop, but now I have a different issue: It is connected to the network because OctoPrint is available, but on the desktop, I'm not able to see the wifi configuration and trying to open raspi-config the wifi setup errors out a "Could not communicate with the wpa_supplicant" error.

Doing a sudo apt update also gives me network errors (cannot resolve host). So I would like to install Chromium but suspect it will fail until I get the network interface sorted.

As I said, OctoPrint is working fine, so I know it is connected to the internet. Looking at the /var/log/syslog file OctoPrint is indeed reporting that it is online and able to access the network. There are no other log messages that I can see to indicate the issue with the network configuration.

Indeed, when I tro to run sudo apt install chromium-browser -y I get all sorts of network errors that it can't access URLs.

I had the same issue install of desktop just left a blank screen with cursor in left hand corner.

Octopi worked perfectly.

Installed 64 bit release Octopi 0.18.0 RC1 on a fully loaded Raspberry PI 4
Tried all the fixes suggested.

So down the rabbit hole I went.

Installed 32 bit release Octopi 0.18.0 RC1
Verified Octopi was working.
Ran scripts/install-desktop -- takes a while
configured to start to desktop on boot

Everything worked. Desktop came up. Configured PI and installed Chrome via apt-get with no issues.

Here is status from bottom of screen on Octopi

OctoPrint 1.5.2 Python 3.7.3 OctoPi 0.18.0

So it appears something has changed in the 64 bit install of desktop.
Been a while since I have been in Unix land. I still have images for 64 bit and I will tinker around when time allows to see if I can find the error and send it in.

Note I did NOT do anything else. No xinit, no xstart, no gui mods

Hope this helps.

Excuse crudeness of this msg. FIRST POST need to learn all the bells and whistles of this tool too.

BTW this is exceptional product and the developers deserve kudos for making this so easy to get into the 3D printing addiction.

1 Like

Hey, sorry but my latest issue appears to be a red herring. After my print ended I rebooted my rasping and everything came up good.

So the answer to this thread is to use 32bit and reboot a few times after desktop install.

Thanks to all who helped. I appreciate it!

Any news on the 64 Bit version ?

Not yet, there hasn't been any work recently on them. You could look at the Github repository to watch for updates: