Despite following all the right setup steps prefectly, Octoklipper is still not connecting to my printer

What is the problem?

I am trying to set up Klipper on my Octoprint setup. I have been following the guides below:

Despite doing everything mentioned in the guides perfectly, I am still unable to connect to my board, the SKR Mini E3 v3.0. When I go into Octoprint, Octoklipper just says Klipper: Standby and clicking "Connect" does literally nothing. There is no output in the terminal, no outputs, nothing. It is just a dead button.

What did you already try to solve it?

I tried setting up Klipper twice. Both times, it has produced the same issue.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Safe mode will actually do something when I click connect, but it doesn't actually connect. It just attempts a handshake which fails every time. Then, it gives up and fails.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (27.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.8.6, Raspbian Lite 64-bit, Creality Ender 3 with SKR Mini E3 v3.0 board, Firefox, Linux.

Here is my printer.cfg file, which I pasted into the editor:

Hello @cray12399 !

I recommend to open a discussion at he Klipper discourse:

Thank you! I was not aware of this forum. Should I close this thread?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.