Development firmware despite latestest firmware update

What is the problem?

According to OctoPrint, my firmware is a development build from Marlin although I am using the latest firmware from my 3D printer manufacturer.

What did you already try to solve it?

Try to update my Printers Firmware over the offical Anycubic site: https://store.anycubic.com/pages/firmware-software

Have you tried running in safe mode?

No I don't think this would solve the problem in anyway.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

Is included in this post.
octoprint-systeminfo-20240311142938.zip (95.9 KB)

Additional information about your setup

I'm printing with an Anycubic Vyper. Depsite installing the latest offical Firmware 2.4.5. from Anycubic OctoPrint notifies me that I run a experimental Marlin Build:

" Info: Firmware Development Build
Your printer's firmware is a development build of Marlin (build date 20210902). It might be more unstable than a release version and should be kept up-to-date."

I have read the linked article which mentions that this can lead to errors with OctoPrint.
What should I do if there is no newer firmware available for my Vyper? Should I deactivate these messages?

Opening a "Get Help" topic starts with a template which asks for information that has historically proven to be the minimum amount of information we need to be successful in helping you. If you really want our help, please provide us with the information we need to do so.

OctoPrint doesn't have the resources or the clout to dictate the firmware installed in every manufacturer's 3D printer. What OctoPrint does is warn users when it detects that the firmware in the printer might cause problems so the user can determine if they actually have a problem. The user can also decide if they wish to be warned or not.

Marlin is an open source project with a license that allows anyone to download the sources and build firmware.

Sry I thought its not needed for this question. I updated the post with all necessarie infos.

Thank you! Around here, there is no such thing as too much detail!