Device descriptor read/64, error -32

What is the problem?

Raspberry Pi 3 B+ and Ender 3 Pro 1.1.4 main board are not talking to each other. It had been working fine for a couple weeks and then the Pi quit recognizing the printer.
I have exhausted my limited knowledge of the Pi but have tried several of the proposed fixes I have read on threads.

What did you already try to solve it?

I have tried 3 different USB cables.
The P3B+ is powered from the printer PSU through a buck converter. I checked the buck converter and it is adjusted correctly to 5V.
I have tried the tape over the 5V pin on the USB cable and it still does not work.
I have re-flashed the Ender 3 Pro main board and reloaded Octoprint on the P3B+.
I can plug a USB drive into the P3B+ and it recognizes it, so I believe the P3B+ USB ports are good.
I can power off the printer, plug in my laptop to the USB port on the main board and it powers the LCD and my laptop can see the board, so I believe the USB on the mainboard is good.

Complete Logs

dmesg.log (22.8 KB)
octoprint.log (31.8 KB)


Additional information about your setup

Octoprint 1.4.0
Octopi 0.17.0
Ender 3 Pro Creality 3D V1.1.4
Firmware TH3D_UFW_U1.R2.B4
Chrome Browser
Windows 10