Device reports readiness to read but returned no data

What is the problem?
Printer stops printing, gives this error message and the print is failed. You know the drill.
'device reports readiness to read but returned no data '
SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)

What did you already try to solve it?
First i tried to google solutions and i have read your FAQ and i think i have taken every step i could find but nothing works.

Steps ive taken so far:

  • Replaced the power supply to a brand new 3.1A (no undervoltage)
  • Changed outlet for the power supply
  • Tried with and without the Pi cam - no difference
  • No other devices connected
  • Changed USB cable to a brand new shielded with a ferrite bead. USB cable is as far from printer as possible.
  • Tried to connect printer to different USB ports
  • No cables are loose
  • I changed the entire Pi3B+ mainboard to another Pi3B+
  • Reinstalled the OS on a brand new 16GB SD card
  • I moved the Pi further from the printer (aprox 1 meter away instead of next to it)
  • I have both tried an upgraded os and a fresh new reinstall from your website.
  • I have blocked the 5V pin on USB cable so it wont power the printer.
  • Tried the dwc_otg.speed=1 thingie, no difference.

Priting from SD card works great but i lack the remote control without octoprint :frowning:

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
octoprint.log (65.6 KB) (1.7 MB)
serial log was too big so i had to zip it.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Pi3B+, octoprint 0.17.0
Plugins used: Spaghetti Detective, Printoid (tried enabled/disabled)
Printer: Creality Ender 5 pro, stock hardware and firmware

I really dont know what to try next...

in the settings, under connection, there is a box for
Request exclusive access to the serial port
Check that box and see what happens

Im having the exact same issue on my wanhao I3 clone. No matter what Ive tried it falls over mid-print. SD print works without issue. Its a shame as I really like the thermal monitoring.

Any findings ? Having the same issue with my Ender 3 pro. Tried the same workarounds...

Well yes.. and no.

Unchecking the request exclusive access seems to work for now despite the fact you should have it checked. I have done maybe 15 long prints (10h+) without any trouble so far, but i guess i just jinxed it :smiley:

Just a random observation. The USB ports on most RPi boards share a single "channel" (not sure what the right name is) so serial communication with the printer and capturing images with a USB camera have to share it. I wonder if this is causing some kind of interference causing the serial communications to occasionally fail?