Did I smoke my printer?

What is the problem?
I was setting up a filament runout switch, defined for gpio24 (physical pin 18) and ground (pin20). Duplicating a setup I have in place already..
I accidentally connected my plug to gpio pins
25 and ground. When I did, the printer display went black.
I shut everything down and restarted. I can connect and move the axis' but cannot seem to make it print or heat anything .
Not sure what to check next..
Not sure why gpio 25 would have made the display go out. .???

What did you already try to solve it?
Disconnected, powered off and back on

Additional information about your setup
latest version on a pi3b.

Does the power supply work? Does the light come on when you flip the switch? If so, is the output 24 Volts? If the PSU is OK did you check to see if you have a fuse on your mainboard? If so, is it blown?

or 12 Volts...

In all: curious.

The steppers need driver voltage, as the heating does.
The logic needs 5V as the display does.

@Egropp: You did not mention what printer you have.

Sorry. My Creality E3 Pro has a Meanwell PSU with a 24 V output. I guess not all printers do. The main board takes 12-24 V input. Main thing is to start at the wall and make sure you are plugged in then make sure the power supply is working. My main board has a very prominent fuse right next to wear the power input terminals are. That would be the next thing I’d check. If there is power going to the board and the fuse isn’t blown look for burn marks on the board and check the cable from the board to the display. If everything looks ok but it still doesn’t work look on the bright side. Consider it an opportunity to upgrade your main board

1 Like

Thinking about it more GPIO 25 (Physical pin 22 is a GPIO pin-max out 3.3V, Max in 3.3V. Current output max on that board is 17 mV. I haven't played with a filament runout sensor yet but my understanding is they are more passive and not current generating. Unless you accidently shorted something else out along the way I'm stumped. What is your config like? Printer? where is your mainboard and where is your Pi? Are they in close proximity? How do you connect your Pi to your mainboard? If I am thinking this clearly the filament sensor wires go to the Pi which was already connected to the mainboard. I don't believe the Pi is capable of generating enough electricity to burn your mainboard without destroying the Pi. If the Pi and mainboard are housed together maybe your disconnected some wires from the mainboard? maybe you accidently shorted the mainboard? If you can still work some of the stepper motors it implies some electricity is getting to the mainboard. Check the voltage output of the heater connections?

I am truly sorry for the lack of detail in my question (it was written in a bit of frustration... :frowning: )
This is a friends SideWinder X1 (stock config), a Raspberry Pi 3b mounted to the right side of the printer and connected via USB. This has been up and running with little issue until i added the Filament Sensor.
I have a similar setup of my own that I have added the same runout switch config (I have made an extension "Y" connector and pulled out only the signal and ground wires from the Sidewinders switch, to be connected to the Pi. This config is working on my machine and I tested the extension on mine before connecting it to his.
While connecting the extension to the Pi, I think i missed the correct pins (I am using a dupont connector so nothing gest shorted to the neighboring pins). When i connected the wire to his pi, i think i must have missed the correct pins because as soon as i connected it, the display on the sidewinder went blank. I immediately disconnected it and the display came back. I shut it down and powered it back up.

From the printer panel, I can home everything and heat the bed / hot end. I have not tried to print from the included Thumb drive yet because i didn't have it handy.

I logged back into OctoPi and tried to start a print job that i have printed earlier in the day. The Pi indicated that the print was starting, but the temp indicators never seemed to indicate they were turned on, looking at the printer control panel for this same job, there was no indication that the bed or the hot end were heating.

I took his Pi home, put my sd card in and brought up my installation and started a print without issue.
What I am afraid may have happened is the communication between the Pi and the printer may have been damaged in some way, i just dont understand what may have happened here.
There are 2 possibilities for incorrect connection that may have happened, #1 i connected between gnd and gpio25, or #2 I connected between gpio23 and gpio24.

Could this in any way have damaged the printers main board?

When you are working on a powered device, bad things can happen.
But you worked on the Pi, not the printer, so the printer should not be affected if you have a short circuit on the Pi.

But as @Bhandler1107 said: you may inspect the printer hardware. And if there are, the fuses. Maybe the LCD light is, what's very uncommon; powered by 24 V.
Even if the light is off, you may slightly see something on the display if it's working.

But before you open the printer case: Pull the mains plug!

1 Like

Thank you all for the input here.. This was almost the perfect trifecta of stoooopid.. :roll_eyes:
#1 Being on a rush to get something installed
#2 Not paying attention to what is actually going on
#3 Failing miserably the 2% rule (the one that says you need to be at least 2% smarter than what you are working with)...

Here is what ended up happening.
I installed the filament Sensors Revolutions plugin and restarted octopi. I connected my "Y" cable to the switch and to the pi. Initially, I had it correct but it didn't work as expected... This was due to #2 above.. When I configured the plugin, I set the switch as normaly open instead of normally closed. Not thinking it through, I moved the wire, this is when the display went out. I pulled the wire and reconnected it to where it should have been. At the same time I pulled my test filament out of the switch..
In this configuration, it worked as it was setup (just not right), as it was (with the switch as normally open), the plugin was seeing this as a filament out situation. Seeing this as an out of filament situation, the print would not start..:unamused: because it should not have.....

After stepping back and looking at it logically, it all fell into place, I corrected the switch config and everything started to work as expected...

Now that my crisis of lackofthinking is over, thank you all for taking the time to read this and offer assistance. I truly appreciate all of the help.


I am however still uncertain why shorting pin 25 to ground would cause the display to go blank.