Different connection behaviour wired vs wireless


Firstly, sorry if this is covered in another post, I’ve scanned and found many discussing similar things, mainly wireless connection issues, but nothing that has helped (although they have given me ideas for things to check, but still I am where I am)...

I'm really not an advanced user but I have managed to setup myself an RPi, configure it with OctoPrint and connected to my Prusa MK3S+ and I have the following situation....

When the RPi is connected to wired LAN, I can load the OctoPrint login page and connect via Firefox (remote Ubuntu machine) using the local RPi IP 192.168.0.xx or the octopi.local url, all is well. In this instance I'm not using SSL (just http://) - [I’ve looked at the guide I found on here to setup SSL and try as I might, I’m not following the instructions, sorry.]

When I disconnect the LAN from the RPi and connect the RPi to my wireless network however, Firefox refuses to load the OctoPrint login page, nothing happens, just a timeout eventually (using either url mentioned). Same result on a Mac using Chrome browser.

At this time, I can ping the RPi and I get a response, so I know it's on the WiFi network.
I can login to my OctoEverywhere account via the same browser and see the printer is online.
I've also ssh'd into the RPi and checked the regional and wireless setup/config which all looks good, to my eye / aligns with the guide I found posted.

When the RPi is on the wireless network I can also connect to my printer from Octopod on my iPhone, using the above mentioned url and I can see the video stream/control the printer.

Maybe some might say just leave the RPi on the wired LAN then but it’s not really convenient by way of LAN port connections in terms of the positions and, when the RPi is connected back via wired LAN again, I can still connect from Octopod on the phone, but it's unreliable (I get lots of cannot refresh errors) and the video stream doesn't work.

So, why is a wired or wireless connection on the RPi causing such variable connection behaviour, primarily why cant I connect from my laptops browsers when the RPi is connected to my wireless home network, using only http. What can I do to get it working?

Some simple hints and tips for dummies’ based suggestions would be so much appreciated. I’m really confused.

Thank you!!

Keep in mind that the Wi-Fi connection has a different IP address that the Ethernet connection.

Thanks - good point but I had noticed/realised, the printer display also highlights. When testing each I've used the same IP address within the OctoPod iPhone app as I'm trying in the browser. Also, Octopi.local I guess is just looking for the server on the network? not actually defining the IP address when I try that

Your DHCP / DNS server (most likely services in your router) is getting confused by seeing two different MAC addresses with the same hostname. It is properly assigning two different IP addresses but the DNS name(s) associated with those IP addresses may not be accurate.

See https://forums.raspberrypi.com/viewtopic.php?t=225433 for more details.

I suggest that you pick one interface and leave the other interface alone.

Going along with what b-morgan has said.
Sometimes routers get confused as mentioned and need to start over without cruft from earlier configs.

I would suggest 3 steps.
First: disconnect the ethernet from the pi.
Second: reboot the router so it no longer remembers the pi as connected to the ethernet.
Third: Reboot the pi so it makes a clean connection via wifi.

Once that is done I would suspect that you will see a noticeable difference in performance.

As also mentioned, do not mix connections to the same device.

Thank you @Ghost / @b-morgan, appreciate your time to share thoughts.
I'd like to pick just the wireless interface and leave the wired alone but the only reason I've switched about is because when I'm away from the printer I need the mobile app, which only works well when the RPi is wireless connected and when I'm with the printer I want to use the OctoPrint interface which is only loading when the RPi is on a wired connection, I wasn't jumping about for fun :persevere:

I've just tried your suggestion @Ghost, after third step I tried connecting via my browser on as well as http://octopi.local/, neither works. I then opened the Octopod app on my iPhone, connects straight in on - I'm lost!

Thank you for the link @b-morgan, I think I'm taking from the final comment that there should be a solution even to using both interfaces, but I didn't really follow the discussion of what would be relevant to change in my instance to just get both remote devices working with just 1 connected RPi interface!

We need to troubleshoot your local area network (LAN) to determine why all devices connected to it cannot communicate with RPi. To do so we need details on both the hardware configuration and the output from some commands on the systems that don't connect.

First, we need to make sure we have a clean configuration so we need to reboot the router, the Ubuntu machine, the Mac, and the RPi (without ethernet connected).

Second, what router (make and model) are you using? It should have a web interface. Can you access it?

How is the Ubuntu machine connected to the LAN? The Mac?

You mentioned using SSH so please verify that SSH still works between all the machines we are troubleshooting. Tell us what works and what doesn't.

For the following, you can capture the output from the commands by using screen -L, type the commands, type exit and the output will be logged in screenlog.0 (use man screen for additional options like changing the output file name). To post the output here, either upload a file or use the </> tool above so that the markdown doesn't mess with the output.

On the RPi and the Ubuntu machine, what is the output of ifconfig , route , cat /etc/resolv.conf. You can also include the Mac equivalent command output if you know those commands. I'm guessing that once we fix the Ubuntu machine access, the Mac will also be fixed.

I'm sure we will have more questions once we see the results so far.

Apologies for disappearing when you were so kindly giving your time to try and help. I've literally just go back around to picking this up again.
The quoted line above got me to thinking, I've never actually tried switching about the Ubuntu machine connection. Has always been wired to the LAN previously. I tried putting it on wireless (along with the RPi on wireless) and, as if by magic, all is working. Strange as when the Ubuntu machine was wired and the RPi was wired it wasn't all working, but it was the Octopod mobile app that wasn't working, and of course the iPhone was wireless LAN. So basically I'm concluding that if one of the clients/parties involved isn't on the same wired or wireless type of connection, then there's a issue. This leads me to think it's a (rubbish?) Sky router which is getting confused mapping the connections? I had a BT router not long ago and while Octopod iOS app wasn't in the mix back then, I had no issues having the Ubuntu machine on wired and RPi on wireless connections.
So for now I'm good and I thank you again. If you have suggestions for how the router maybe manually configurable to resolve then I'd be intrigued?

With the experiences I have had with networking and various routers, I can categorically say that sometimes it is easy to fix communication issues by simply rebooting the router so all connections are newly configured and nothing hanging in memory. This usually works with both wired and wireless issues.

Just my $0.02