Disable Wifi Raspberry pi 4 Octopi

What is the problem?
Due to unreliable wifi in my location, i would like to disable wifi completely and use ethernet connection. I cannot find setting / command to do this.

What did you already try to solve it?
Cannot find parameter to disable wifi in either

Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Raspberry Pi 4 8Gb
Latest Octopi

Just plugin the ethernet cable and you are fine.
Cable connection always is preferred.

If you want to be sure, delete your WiFi credentials in octopi-wpa-supplicant.txt.

Keep in mind, that the cable connection will have a different IP address.

1 Like

Thanks for that, i have made the necessary changes.

Appreciate it..

1 Like

You can also turn off the wifi radios on the pi by adding:
To the end of the /boot/config.txt file

Just for Clarification on this, & make it clearer for future reference,
would the below be all correct, or do you need to comment out all lines in octopi-wpa-supplicant.txt

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

#	ssid="IITSxxxxxxx"
#	psk=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Along with this in /boot/config.txt

Or does leaving octopi-wpa-supplicant.txt as is & just changing config.txt fine for if I wish to occasionally re-enable it when working on switches.


Have an environment here with 7 AP's & over 65 clients at most times,
So getting rid of the radios on my 4 Pi's has it's benefits.