Disk image corrupted

What is the problem? after download and trying to open octopi in sd card i get a disk image corrupted warning

**What did you already try to solve it?**nothing i think the download is ccorrupted

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

So what's the question? Try downloading it again?

What OS are you trying to mount the image on? Why are you trying to mount it? Did you image the SD card and try booting the RPi in question?

  • how are y'all "mounting" this image?
  • What do you mean you're "mounting" it?
  • Which software are you using to burn it (which is what you should be doing, not trying to mount it)?
  • Where are you seeing the corruption error? Is your OS saying it's corrupted or your burning software?
1 Like

I have run in to the same problem no mater what when i down load the zip file of the iso and extract it windows state it's corrupted and i have tried to down load it several times over several computers over the year with no luck.

You aren't meant to mount/open it using windows, you're supposed to take the image, load it into an SD writing program (etcher, win32diskimager, rufus, etc), and flash it directly to an SD card. The image isn't readable by windows, it's a linux filesystem image.

I don't think I phrased that correctly the ISO file is what is corrupted and when I try to load it to a SD card that is at which point Windows states it is a corrupted ISO file and that it cannot be burned to the SD due to its corruption.

As I understand, you tried to copy the ISO file to the SD card. That won't work.
You need a small program like Etcher to create a bootable SD card.
ISO files a 1:1 copies of complete storage devices with everything on it: Bootloader, directories, files, data...

This is very informative.

1 Like

As I said, you aren't meant to use "windows" at all to open the file. Windows shouldn't be telling you anything, because windows itself should not be interacting with the image file in any way what so ever. It's a linux image file, of course windows can't read it. MS gave windows the ability to mount ISO files and burn them to CD, but this is one kind that it won't have a clue what to do with. You need a 3rd party program.

For more information, see the raspberry pi documentation on how to write an sd card image https://www.raspberrypi.org/documentation/installation/installing-images/README.md

you're really being no help I've also use third-party programs to try to upload it once again it would say the ISO file is corruptit would usually take five or six downloads to get a non corrupt file and even then afterwards the program would still not run properly on the Raspberry Pi saying that there was a critical error in the programming.I have to use for different aftermarket ISO burning files to upload it onto three different brands of SD card and using 3 different generations of raspberry pies to try to use this none have worked.I was merely using the Windows 10 ISO burn file option because it was there and a new option on my desktop to see if it would work which as with all the other ones it did not. On the other hand other Raspberry Pi programs have worked.

If it were me, I would try to cut Windows/Edge out of the picture completely. It's possible that they're trying to help you in ways which aren't helpful.

curl -o ~/octopi-stretch-lite-0.15.1.zip https://storage.googleapis.com/octoprint/stable/octopi-stretch-lite-0.15.1.zip

Then open Etcher, select the ~/octopi-stretch-lite-0.15.1.zip file as downloaded, select the microSD card which has been mounted into your computer and etch it.

Does Etcher automatically unpack zipped image files? Because otherwise there's an unzip step missing here.

@Morgan_Hawkins Use Etcher or Win32Diskimager to flash the unpacked file that's contained inside the ZIP. Don't use anything else that claims to be able to burn ISOs. Don't try to mount the image. Just follow these instructions that are also linked in the official install guide.

@foosel Yes, from memory you can just load zip files into etcher.

you're really being no help I've also use third-party programs to try to upload it

Well how am I supposed to know that? You didn't give any details on what you've tried, you just say "windows tells me it's corrupted", well the only time I've had "windows" say anything, is by trying to open disk images in windows explorer. "Windows" has never told me any image is corrupted when using 3rd party image writers because windows doesn't interact with them.

Are you saying the image writing software is giving you an error? Which image writing program tells you it's corrupted? How did you unzip the file? Did you check the CRC of the downloaded file using the hash provided on the download page?

Please list every step you're doing, no matter how small or irrelevant you think it is, and the name of the program you are using to do it.

Hey everyone,

I see this has died down a bit, but I too share the issue. I think the problem stems from following YouTube tutorials etc. When I follow the steps (using 0.17) and use the install guide to flash my micro SD card I can not see the boot directory to edit the files to add my WiFi information. I understand I should have two partitions after the image has been flashed, but WINDOWS only shows 1 and its unreadable. (Windows 10 Home Version 1903). So I cant follow the setup steps after the flash step.
BUT when I place the same SD card in my Kali box, I can edit the files no problem. The setup process seems to be completed just fine!
I think the issue is there is no windows compatibility (a guess)? I don't see that as a major issue, except I don't imagine a lot of folks have access to a Linux distro to set up the wifi.
Again, my card is configured and working thanks to Linux, but are others having issues due to using Windows? I sure was!

I hope this clarifies why it appears to work for some, and not for others.


On Windows after Etcher, Win32DiskImager, Rufus, etc. has transferred the image to the SD card, remove the SD card and reinsert it. Cancel or close the needs to be formatted dialog box, and the boot partition should be readable.

Windows sometimes "remembers" the partition layout of SD card before the image was written. Removing and reinserting will cause Windows to read the partition table again.

1 Like