What is the problem?

Octoprint "layer indicator not found in file" when sliced with the Prusaslicer. It worked perfectly with the Prusaslicer until I upgrade the DisplayLayerProgress plugin.
The Before layer Change G-code setting in the slicer is
G92 E0

On uploading a file, it appears to upload OK but you cannot select it to print and you just get the progress circle of dots going around and around for current height and layer display.

Is it possible to downgrade this plugin.

What did you already try to solve it?

Restarted in SafeMode
Sliced in Cura, it works but the layer count is two layers behind that shown in the G-CodeViewer

Have you tried running in safe mode?


Did running in safe mode solve the problem?


DisplayLayerProcess log

2021-03-17 23:13:40,272 UPDATE DISPLAY: frontEndCall [1995776016::MainThread]
2021-03-17 23:13:40,284 SEND-PRINTER: not send, because duplicated command:M117 0% L=19/19 [1995776016::MainThread]
2021-03-17 23:13:41,361 EVENT: SettingsUpdated [1950868576::Thread-1]
2021-03-17 23:13:43,368 UPDATE DISPLAY: frontEndCall [1758921824::Thread-444]
2021-03-17 23:13:43,368 EVENT processed::SettingsUpdated [1950868576::Thread-1]
2021-03-17 23:13:43,373 SEND-PRINTER: not send, because duplicated command:M117 0% L=19/19 [1758921824::Thread-444]
2021-03-17 23:13:43,377 SEND-EVENTBUS: not send, because duplicated dict:{'changeFilamentTimeLeft': '-', 'feedrate': '3000', 'updateReason': 'frontEndCall', 'totalHeight': '3.8', 'totalLayer': '19', 'estimatedEndTime': '23:13', 'changeFilamentCount': 0, 'estimatedChangedFilamentTime': '-', 'printTimeLeftInSeconds': 0, 'totalHeightFormatted': '3.8', 'currentHeight': '14.20', 'printTimeLeft': u'0s', 'lastLayerDuration': '-', 'averageLayerDurationInSeconds': '-', 'lastLayerDurationInSeconds': '-', 'changeFilamentTimeLeftInSeconds': 0, 'printerState': 'operational', 'averageLayerDuration': '-', 'm73progress': '100', 'feedrateG1': '3000', 'feedrateG0': '12000', 'fanspeed': 'Off', 'progress': '0', 'currentHeightFormatted': '14.2', 'currentLayer': '19'} [1758921824::Thread-444]
2021-03-17 23:14:23,215 EVENT: MetadataAnalysisStarted [1950868576::Thread-1]
2021-03-17 23:14:23,216 EVENT processed::MetadataAnalysisStarted [1950868576::Thread-1]
2021-03-17 23:14:23,221 EVENT: FileAdded [1950868576::Thread-1]
2021-03-17 23:14:23,268 EVENT processed::FileAdded [1950868576::Thread-1]
2021-03-17 23:14:23,314 EVENT: UpdatedFiles [1950868576::Thread-1]
2021-03-17 23:14:23,315 EVENT processed::UpdatedFiles [1950868576::Thread-1]
2021-03-17 23:14:23,321 EVENT: Upload [1950868576::Thread-1]
2021-03-17 23:14:23,322 EVENT processed::Upload [1950868576::Thread-1]
2021-03-17 23:14:26,612 EVENT: MetadataAnalysisFinished [1950868576::Thread-1]
2021-03-17 23:14:41,366 EVENT: FileSelected [1950868576::Thread-1]
2021-03-17 23:14:41,388 UPDATE DISPLAY: frontEndCall [1950868576::Thread-1]
2021-03-17 23:14:41,401 SEND-COMMAND: M117 0% L=-/- [1950868576::Thread-1]
2021-03-17 23:14:41,403 QUEUING-HOOK: M117 0% L=-/- [1950868576::Thread-1]
2021-03-17 23:14:41,409 SENT-HOOK: M117 0% L=-/- [1861207136::comm.sending_thread]


Additional information about your setup

OctoPrint version 1.5.3
OctoPi version 0.17.0
Raspberry Pi 3 Model B Plus Rev 1.3
Printer Ender 5, Motherboard 4.2.7
firmware Marlin Creality 3D
browser Chrome
operating system Windows 10 Home

Tagging @OllisGit :slight_smile:

Problem found, The plugin did not play well with another Slice Time Estimator, it did not work is SafeMode until deleted so I guess it was an issue related to a python conflict.


to the prusaslicer gcode section Before Layer Change g-code.

Source info for the fix Layer information doesn't display when using slic3r gcode even with enhancement 8 settings Β· Issue #36 Β· OllisGit/OctoPrint-DisplayLayerProgress Β· GitHub

1 Like