Do I need to change ports if using multiple cameras (one per Raspberry Pi)?

Camera model

rPi Camera Module v2.1

What is the problem?

Yesterday I initialized three Raspberry Pi's with separate instances of Octoprint (unique URLs). Everything seemed to work fine until I started connecting my camera modules and now none of them seem to be working correctly (the stream in the Control tab is black, as if no camera is connected).

What did you already try to solve it?

After doing some research it seems like cameras default to port 8080, and now I'm wondering that (even though I'm using three different Raspberry Pi's, with different URLs), could there be a clash if all cameras are defaulted to port 8080?

I'm quite new to this so sorry for the noob question, I just wanted to see if anyone had any advice on this before investigating if there are hardware issues. Especially as the cameras were all working fine when initializing the Octoprint instances, but now that they're all set up, there seems to be issues -

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (15.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

For all 3 printers:
OctoPi 1.0.0
OctoPrint 1.9.3 (camera stack build)
Prusa Mini
Firmware 5.1.2
rPi Camera Module
Accessing OctoPi via Google Chrome, and OctoPod iOs application.
Windows 10

No, that shouldn't be an issue.

I think what you might be running into is the bug with camera-streamer where it dies after a period of time after starting up.

1 Like

Thanks for the reply - I'll have a look into the crash -

I've also just run a few recommended diagnostics that I found while browsing here - would these indicate a hardware issue or would these commands also show the same thing if the camera streamer crash was occurring?

jake@mini1:~ $ vcgencmd get_camera
supported=1 detected=0, libcamera interfaces=0

jake@mini1:~ $ libcamera-still -o test.jpg
Preview window unavailable
[0:05:16.332233204] [1131]  INFO Camera camera_manager.cpp:297 libcamera v0.0.5+                                                                                                                                                             83-bde9b04f
ERROR: *** no cameras available ***

just found out in discord from someone else, that the detected=0 was because the camera wasn't loaded. check config.txt for the below line and make sure it's set to 1 and not commented.


Thanks, I think that fixed it- the camera is displaying now but it has these blue lines going across

Edit: Seemed to be a faulty camera, replaced the module and everything is working fine now. Thanks for the help!