Don't know how to start

I have a raspberry pi 3B+ and a 7" touchscreen. Octopi image is installed on the sd card. I booted up and entered the user 'pi' and the password 'raspberry'. Now I see 'pi@octopi: ~$. What next?

I tried:
sudo usermod -a -G tty pi
sudo usermod -a -G dialout pi
and then:
~/OctoPrint/venv/bin/octoprint serve
even though it says in the get help guide that it should say 'pi@raspberrypi:~$' but I didn't/don't know what else I should try.

The raspberry is not connect to a PC and/or Windows, just to the touchscreen. I don't even know if it is connected to the internet. I tried to install a touch driver for the screen but it failed to connect to github.

Now that you have a screen installed you have to figure out which local interface you want to use. I personally like OctoDash, but there is also TouchUI and OctoScreen as options.

Have you managed to open OctoPrint's main UI in the browser to set that up? I would recommend doing that before trying to setup a touchscreen UI, as you can't access everything through there.

No, I haven't. That's is the problem that I have. @jneilliii suggested to get OctoDash, or similar, but I can't get connected to github and I have no idea if the wifi is connected or not since there is no indication of it either way and I don't know how to check if it is or not.

Ok. Lets forget about the touchscreen connection for a minute and get started on using the OctoPrint UI. The mention of OctoDash was assuming you already had OctoPrint up and running because you were talking about setting up a touchscreen.

You seem to have mixed together some different guides for how to setup OctoPrint, installing the OctoPi image vs. a manual install of all the components. Have you installed the OctoPi image using the Raspberry Pi imager, setting up the wifi in there before putting the SD card in the Pi?

Once it is installed and the wifi credentials are entered, you should be able to access it using http://octopi.local or the Pi's IP address. You can find the IP either through your router's admin panel, or something like Angry IP Scanner. If you still can't get it connected to the network then let us know and we can troubleshoot from there.

After entering http://octopi.local I got -bash: http://octopi.local: No such file or directory.
I'll check right now to see if I can connect to another wifi router and will get back.

Sorry, I missed a key word from there - OctoPrint's UI is meant to be opened in the browser. On another device, such as a PC or laptop, you should be able to enter those addresses in the browser providing it is connected to the network. You can't open websites in the command line.

Yeah, forgot to mentioned that it also said 'http:' command not found

You aren't reading what I'm writing. Open your web browser on another device. I don't know why you are typing http: into the command line at all.

Well, I had written http: since that what you have posted in your first post. "you should be able to access it using http://octopi.local"

I saw on YT someone mentioned the command 'ifconfig'. I tried it and the list that popped up didn't include and IP which tell me that my Raspberry is not connecting to the internet for some reason. If I'll use a Raspberry image, which I had on the Raspberry before, will I then be able to run/install Octopi?

The instructions on the official OctoPrint site are very clear on how to install the octopi image. Try those instrucitons. Just follow the bits in the Installing OctoPi section in order.

I'm sure the OctoPi is installed properly. I had it burn the image on the SD card with Raspberry Pi Imager. I just can't connect to the wifi for some reason. I now have the ethernet cable installed and pinging github showed transfer of packages without error. Now I'm trying to install OctoDash.

Sorry to butt in, but doesn't the wifi need to be configured on the pi in raspi-config?

No, not if you follow the setup instructions on the download page, which take care of that in step 3 without ever booting the pi.

I had it set up that way but the wifi didn't work. I don't blame it on OctoPi, it could very well be a problem with my Raspberry. I didn't check it out yet.

But, since I have your attention. I have a 7" LCD display with touch and the touch doesn't work. I couldn't find a driver for it. The seller, and other buyer, say that it works out of the box with the Raspberry Pi image. The manufacturer of a very similar screen, Waveshare, says the same thing, their display works out of the box with Raspberry Pi image.
Are some, or all, display drivers are omitted form OctoPi? I didn't try my display with a Raspberry Pi since It took me so long to get OctoPi and OctoDash to work and I don't feel like going through the whole process again if it's not absolutely necessary.

Depends on when those drivers were released to the main Raspberry Pi OS. The OctoPi image is a frozen point in time relative to drivers, so you may need to SSH to your pi and run sudo apt update and sudo apt upgrade to get the latest available. Also, some of those screens depending on how they connect still require a USB connection to support the touch interface.

I did the update and upgrade and the screen is connected to the Pi with a USB to the port that says 'touch' and it still doesn't respond to touch.

Use the octopi image from It is designed to run headless, so pretty much ignore the touchscreen. Use it insteady of using putty on a pc.

I'm not sure what you're trying to tell me. I never mentioned PuTTY. The idea behind OctoDash IS to use a touch screen for ease of use.

Headless mean no terminal. The Octoprint setup insructions tell you to use PuTTY (from a PC) to login for command line access to , for example, change the password.