Doubled motor steps in prints

What is the problem?

When I do motor movements via OctoPrint (eg. to move the extruder upwards) then it happens very often that after starting a job the steps are doubled. That means that the job size on the bed is much bigger than it should be. If the normal size is larger than half the bed then in case of an error the extruder wants to drive beyond the bed in run into the mechanical stop.
When I turn off the printer and on again, the job now works fine.

What did you already try to solve it?

Firmware update, new installation of OctoPrint

Have you tried running in safe mode?

Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (89.0 KB)

Additional information about your setup

OctoPrint v1.9.3 running on Raspi 4, Anycubic Kobra Plus - original firmware

Ha interesting

But everything works, if you don't move the axis in OctoPrint and just start the print?

Yes, in this case everything works fine...

Could you please post your start gcode?

Hello. Which GCODE do you mean? In Octoprint, the start GCODE (Section GCODE-Scripts in Settings) is empty. In CURA this start GCODE is active:

G28; Fahr zum Nullpunkt
G92 E0; setze den Extruder auf Null
G1 Z2.0 F3000; Druckkopf 2mm nach oben fahren
G1 X10.1 Y20 Z0.28 F5000.0; Fahre an die Startposition X10.1 Y20 Z0.28
G1 X10.1 Y200.0 Z0.28 F1500.0 E15; Ziehe eine Linie von der Startposition aus nach Y200
G1 X10.4 Y200.0 Z0.28 F5000.0; Bissl zur Seite bewegen
G1 X10.4 Y20 Z0.28 F1500.0 E30; eine 2. Linie nach vorne ziehen
G92 E0; setze den Extruder auf Null
G1 Z2.0 F3000; Fahr die Düse 2mm nach oben

Is this what you mean? Thanks for your help!

Have you ever tried safe mode?

Also enable serial.log, try again and attach the new systeminfo bundle to your next post.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.