Download OctoPrint 1.9.3 image?

Where can I find the *.img file for Octoprint 1.9.3 ?

I tried searching through the github but can only find the source files.

Or can I make Raspberry Pi Imager somehow find/use a previous version?

Thank you

There is no image of OctoPrint.

OctoPrint sits upon an OS, in usual case OctoPi.

You can revert an existing OctoPrint.

ok where can I download OctoPi 1.9.3 image file?

if you go to - Download & Setup OctoPrint you can download version the IMG

where can one find the IMG for 1.9.3?

You can download any previous builds from here Releases · OctoPrint/OctoPi-UpToDate (

May I ask why you need an OctoPi image with OctoPrint 1.9.3? Do you have some issues with 1.10.0? It would be much better if we could resolve the issues, rather than ignoring them by using older versions.


Thank you for the link it worked.

I have few Raspberry Pi Zero W's that I use for my few printers. I was asked to setup one like mine and when I got to the OctoPi setup, I ran the usual Raspberry PI Imager. The Imager updated to 1.10. I ran everything as normal but it just will not move on from " The OctoPrint server is currently not running" I left it on over night thinking it might have to compile on the older pi. After 8 hrs still the same screen. Now the other Zero W's that were running 1.9.3 updated from the web and have no issues I have found so far.

I teach myself from youtube. I have tried the local community center and I am the only one that has asked if others have come to start a local group. I see a few others in my little town do 3D printing but no one wants to talk or share for fear of losing there IDK power? knowledge.

I'm very slow on learning and have limited time with my family / job. It leaves little time for learning and then I have no one to talk to in person.

Again thank you for posting the link I have the printer up and working now vs (over a month, on average for myself to teach myself) while learning how to SSH / Telnet into it.

I'm working on getting a little group together but the only people I seem to be able to get excited for it are the smaller children (8 and 10yrs) in the neighborhood, printing toys or other basic design things from tinkercad.

We have a pretty strong community here and in Discord with several people around to help through these things. Your specific issue sounds like something we've already started investigating. It seems to be specific to the pi zero w and older pi models. There was an SSH approach to get around it, but your method of imaging the older version would also work just as well.

1 Like

Hello, can you send me the link to the discord please ?

1 Like

FWIW in relation to the original issue, the 1.10.1 release (and it's accompanying OctoPi build) should work fine to install on an RPi Zero. It's still not recommended or supported as it's severely underpowered, but it is still compatible should you choose to use it.

I have (5) Pi Zero W's, (3) updated to 1.10 with no issues, (2) will start to update go to reboot and then hang. I have tried about (5) times each on them with consistent results. In the end, I pulled (2) sd cards and did a swap. Now all are running OctoPi 1.10 with no issues noticed other than the beginning with failure to update.