The OctoPrint server is currently not running with no logs

What is the problem?

I see

The OctoPrint server is currently not running

But there are no logs.

I know there are other duplicates of this issue, but I've tried the solutions I've found without luck.

What did you already try to solve it?

  • I kept the default username/password, pi/raspberry
  • There was no ~/.octoprint/
  • I checked and expanded the filesystem
pi@octopi:~ $  df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        15G  2.0G   12G  15% /
devtmpfs         55M     0   55M   0% /dev
tmpfs           183M     0  183M   0% /dev/shm
tmpfs            74M  940K   73M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
/dev/mmcblk0p1  255M   52M  204M  21% /boot
tmpfs            37M     0   37M   0% /run/user/1000
  • I tried starting on safemode
  startOnceInSafeMode: true
  • Upgraded
sudo apt update && sudo apt upgrade
  • Tried random commands I saw online
pi@octopi:~ $ ~/oprint/bin/octoprint safemode
Illegal instruction
pi@octopi:~ $ ~/oprint/bin/octoprint serve
Illegal instruction
pi@octopi:~ $ ~/oprint/bin/octoprint serve --safe
Illegal instruction
pi@octopi:~ $ sudo ncdu /.

  300.5 MiB [#         ] /var
  223.7 MiB [#         ] /home
   51.3 MiB [          ] /boot
   17.1 MiB [          ] /opt
    4.9 MiB [          ] /etc
  944.0 KiB [          ] /run
   52.0 KiB [          ] /root
   48.0 KiB [          ] /tmp
e  16.0 KiB [          ] /lost+found
e   4.0 KiB [          ] /srv
e   4.0 KiB [          ] /mnt
e   4.0 KiB [          ] /media
    0.0   B [          ] /sys
.   0.0   B [          ] /proc
    0.0   B [          ] /dev
@   0.0   B [          ]  sbin
@   0.0   B [          ]  lib
@   0.0   B [          ]  bin
  • Checked the permissions:
pi@octopi:~ $ ls -lh /var/log/
total 1.2M
-rw-r--r--  1 root root             18K May  2 21:33 alternatives.log
drwxr-xr-x  2 root root            4.0K May  2 21:20 apt
-rw-r-----  1 root adm             7.8K May  2 21:47 auth.log
-rw-r--r--  1 root root               0 Sep 22  2022 bootstrap.log
-rw-rw----  1 root utmp               0 Sep 22  2022 btmp
-rw-r-----  1 root adm             158K May  2 21:47 daemon.log
-rw-r-----  1 root adm             4.0K May  2 21:46 debug
-rw-r--r--  1 root root            232K May  2 21:35 dpkg.log
-rw-r--r--  1 root root             24K Oct 27  2022 faillog
-rw-r--r--  1 root root             484 Oct 27  2022 fontconfig.log
-rw-r-----  1 root adm              12K May  2 21:46 haproxy.log
drwxr-sr-x+ 3 root systemd-journal 4.0K Sep 22  2022 journal
-rw-r-----  1 root adm             112K May  2 21:46 kern.log
-rw-rw-r--  1 root utmp            286K May  2 21:47 lastlog
-rw-r-----  1 root adm             137K May  2 21:46 messages
drwxr-xr-x  2 root adm             4.0K Oct 27  2022 nginx
drwx------  2 root root            4.0K Sep 22  2022 private
drwxr-xr-x  3 root root            4.0K Sep 22  2022 runit
-rw-r-----  1 root adm             300K May  2 21:47 syslog
-rw-r-----  1 root adm              28K May  2 21:46 user.log
-rw-r--r--  1 root root             49K May  2 21:46 webcamd.log
-rw-rw-r--  1 root utmp            9.8K May  2 21:47 wtmp

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Couldn't download it

**pi@octopi**:**~/.octoprint $** ~/oprint/bin/octoprint systeminfo .

Illegal instruction

Update about the illegal instruction

I tried this I found online. No luck yet:

source ~/oprint/bin/activate

(oprint) pi@octopi:~ $ pip3 uninstall -y numpy && pip3 install numpy==1.21.4
WARNING: Skipping numpy as it is not installed.
Looking in indexes:,
Collecting numpy==1.21.4
  Downloading (12.2 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 12.2/12.2 MB 1.1 MB/s eta 0:00:00
Installing collected packages: numpy
Successfully installed numpy-1.21.4

[notice] A new release of pip available: 22.3 -> 24.0
[notice] To update, run: pip install --upgrade pip
(oprint) pi@octopi:~ $ sudo systemctl restart octoprint: 

The "illegal instruction" part of your command is the problem here. Nothing OctoPrint related seems to run. Most likely, nothing using that Python install will run. Illegal instruction is normally triggered by trying to run code compiled for a different platform, or it is corrupted.

Is this a brand new install? What Pi model is it installed on?

It’s is a brand new installation, indeed. I’m installing it in a Zero W. It’s my first attempt with OctoPrint before getting something more powerful.

how did you install it? What size SD card?

I installed it with the Raspberry Imager: Other Specific Purpose OS > 3D printing > OctoPi (Stable)

On a 16Gb card.

The OctoPrint server is currently not running after upgrading to 1.10


How does this help to solve the problem?

I'm a bit confused, your command line options say ~/oprint....

Should those be ~/octoprint.... ?

I may be way off here - I don't use OctoPi and have never seen it

You can also run "which octoprint" to find where the executable is located - ensure it's there and now where it is. If by chance that doesn't work, run "sudo updatedb" and then "locate octoprint" to see where things are. (note: those are generic *nix type commands, again - not specific to OctoPi, so they may not exist either)

When did I mention that?

No - on OctoPi, the virtual environment used is called oprint. If you install it yourself, you can call it whatever you want.

1 Like

Have you tried flashing the SD card more than once? Or a different card? I don't think I've ever seen it this broken out of the box - it's the same binary that everyone else runs.

Have you used this Pi Zero for any other projects before? Has it worked properly for you before?

I should note that while OctoPrint & OctoPi will run & is compatible with the Pi Zero, it is not a supported device because it is not powerful enough. A Pi Zero 2 is a much better choice if you want the smaller form factor.

Cool, thanks, what I get for try'n without know'n

I just ran into the same problem. I've been running OctoPi on a Pi Zero W for a year (with webcam turned off) but my SDcard died and I was trying to re-install.
Since './octoprint help' worked ok but not './octoprint systeminfo' I figured it might be a problem with a python dependency. Sure enough when I ran './python -v' then 'help()' then 'modules' I also got an Illegal Instruction error immediately after it imported netifaces2. The stock OctoPi install had netifaces 0.0.22. Dependency tree showed that OctoPrint needs >=0.0.21,<0.1.

So I downgraded netifaces2 to version 0.0.21 and then was able to successfully start the octoprint service.

sudo -u pi ~/oprint/pip install --force-reinstall -v netifaces2=0.0.21

I don't know if 0.0.22 is incompatible or just corrupt on install, but this seems to work for now.


Useful information to have while this issue is investigated, thank you!

This actually fixed it! I had to modify the command a bit:

sudo -u pi ~/oprint/bin/pip install --force-reinstall -v netifaces2==0.0.21

Added the bin folder and ==


Yeah, that's my bad. That's what happens when I don't copy/paste.

1 Like