Dpkg: unrecoverable fatal error

What is the problem?

I upgraded to OctoPi 1.0.0, OctoPrint 1.8.6 via the Raspberry Pi manager and restored my system from the back made just before, my setup included Samba and a drive mapping from my windows PC. After the install was complete my drive map no longer worked and I find no windows share, so I tried to re-install Samba and received a fatal error.
I know little about Linux but followed the documented process I used during my initial setup.

What did you already try to solve it?

sudo apt-get update
sudo apt-get upgrade -y
sudo reboot
sudo apt-get install samba samba-common-bin

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230226185953.zip (110.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Version 1.8.6
Version 1.0.0, running on Raspberry Pi 3 Model B Plus Rev 1.3
TinyMachines D2.0.9_DW7.4.3
Windows 10


Please post the output of the terminal here. The systeminfo bundle only contains OctoPrint related logs.

The pre ious version of octopi you were running was under PiOS Buster. Octopi 1.0.0 is Octopi Bullseye. Your backup of system files is not compatible with Bullseye. At this point I would re-flash the SD card and reinstall all your extras manually and reconfigure them.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.