Easy servo octo pi plugin issues

What is the problem?

when i follow the instructions on setting up the easy servo through sshing into the pi, everything goes good until i hit these commands.....

sudo systemctl enable pigpiod
sudo service pigpiod start
sudo shutdown

the sudo systemctl enable pigpiod command works
but when i type in this command sudo service pigpiod start and hit enter, it gives me this message.....
job for pigpiod.service failed because the control process exited with error code.
see "systemctl status pigpiod.service" and "journalctl -xe" for details.

now i'm a total newb at this so im not sure what is going wrong, or how to view the
systemctl status pigpiod.service or journalctl -xe, or how to fix it
any help will be greatly appreciated

What did you already try to solve it?

nothing i followed all the steps correctly

Have you tried running in safe mode?

????

Did running in safe mode solve the problem?

??????

Systeminfo Bundle

You can download this in
octoprint-systeminfo-20221114020401.zip (32.7 KB)
OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

Hello @dhc2022

What instructions? Link?

BTW: Please put some code script ending tokens (```) after the the code lines at the start. Then the systeminfo bundle would be visible for us.

if you got to the easy servo plugin page, it has all of the coding instructions to "set it up" and i followed those to the letter and still get those errors

I see.
And the systeminfo bundle (see my first post)?

how and where do the script ending tokens go?

It should look like this
grafik

hopefully those ''' work lol also the system bundle is a zip file it said not to unpack it.
Also im not sure what the system bundle is needed for lol im trying to accomplish this Anycubic Vyper Parts Swiper - YouTube without usings a mossfet but so far im not even sure my servo is getting power. its plugged in to power but i can still manually move the arm lol and nothing works in octoprint on the easy servo side, the servo wont move or make a noise at all. i made a 5volt adapter that uses a phone wall charger adapter and and old usb charging cable i cut the end off and soldered onto the servo connections, so it has power from that, im not sure if its enough power 5 volts 1 amp i think.

1 Like

Concerning your install issue, maybe @jneilliii knows more.

hopefully that person sees this question lol

I noted him in my post

Unfortunately I don't think I will be much help here. I just assisted the plugin author with making the plugin as kind of a tutorial for them. It also appears that @FranFran might be on sabbatical to OctoPrint plugin development.

Only thing I could recommend is looking up install instructions directly for pigpio/pigpiod on a pi and possibly look through issues on the plugin's repository on GitHub for any possible hints.

1 Like

ok so i had my buddy give it a try on his raspberry pi and he followed all the step by step instructions and it worked for him, im wondering why mine wont let it happen

The instructions to follow are, after the
sudo service pigpiod start <-- this trys to start the pigpiod service on the system
command fails, try using the commands
sudo systemctl status pigpiod.service. <-- this tells you the status of the service, and briefly why it failed

Then try:
sudo journalctl -xe <-- this tells us what the recent system journal contains
(the journalctl command puts the output into a "pager" called less, which you type q to get out of).

Copy the output of those into a reply. They might give you (and us) a clue what is actually failing. Without that, we're all flying blind trying to help you.