EEPROM CRC mismatch connecting to printer

What is the problem?

I am getting this Error after the last OctoPi update

Error reported by printer

Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: EEPROM CRC mismatch - (stored) 33767 != 49747 (calculated)!

What did you already try to solve it?

Enable automatic firmware detection

Have you tried running in safe mode and if so did it solve the issue?

Nooctoprint.log (171.6 KB) octoprint.log (171.6 KB) serial.log (444 Bytes)

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

Raspbarry Pi 3 B+ OctoPrint version 1.42 OctoPi version 0.17.0 printer Ender 5 Plus firmware ver 1.70.2 BL browser Window Edge operating system Windows 10


If your printer has an LCD screen look for a reset to factory defaults. That's the best advice I can give you since you ignored:

Additional information about your setup
OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


No Reset that I could find. Added more information about the system.

Goto Control -> Restore Failsafe -> Restore factory settings

From the Ender 5 Guide Book

1 Like

@rchristensen, thanks for adding that additional information. With it, @Ewald_Ikemann (thanks) provided exactly what should fix the problem.

1 Like

The Ender 5 Plus I have does not seemed to have those menus

Then maybe somewhere else. This one is essential.

If it is not there, I strongly recommend to upload a new firmware.

If you are connected to the printer with OctoPrint, you can type in M502 in the terminal.

The issues is I can no longer connect to the Printer with OctoPrint. It worked all last week. There was an update to OctoPrint now i get this.

I have looked on Creality web site for a firmware update there is none I have the latest.

Actually the Ender 5 Plus has no possibility to reset the EEPROM.

You may have to contact the Creality support.

Just to make this absolutely clear: this error comes from your printer, OctoPrint only displays it to you, it is not the cause of it.

What you could do however is tell OctoPrint to not disconnect on it (somewhere in Settings > Serial Connection > Behaviour if I remember correctly) and see if that allows you to proceed with connecting (and maybe resetting that way).

1 Like

If you can get OctoPrint not to disconnect, you can type M502 followed by M500 on the terminal tab and that should reset the EEPROM.