Ender 2 Pro freezes

What is the problem?

I have an Ender 2 Pro with board 2.4.s4, that I understand it s kind of problematic since there are no updates available, still? Is there that it can be done to stop getting pauses/freeze from time to time in the middle of print, pause that creates blobs and bad quality.

What did you already try to solve it?

I have tried running octoprint from android, from windows. I have tried to disable all kind of settings that maybe can help the comm problem between printer and host.

I also tried to use klipper with octoklipper but when i press connect after octoklipper plugin is installed and restarted, nothing happens, no error, no movement

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Didn't try

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20230406154140.zip (16.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint on windows Version 1.8.7

Well you can build your own updates

we need to know what kind of freezes you have
does it happen also on simple models like let's say a pyramid or more on complex models like a sphere?

you could upload a picture of those blobs if you aren't sure

you have to flash the klipper firmware to the printer if you want to use klipper.

I have no idea how to build or implement updates. I have to put back the original firmware and I will send examples photos.
My main desire is to use octoprint with original firmware without those pauses

I managed to install a klipper firmware and octoprint or mainsail print allright without pauses but I really don’t like the complexity and unecessary features, besides the fact I can t run printer without a host.

So I will comeback with examples

Here are the examples

I had one episode where my printer paused.

Checking things out I found octoprint was not keeping up with the rate the printer was emptying the buffer and the pause was caused by an empty print buffer on the control board. For me, slowing down the printer fixed it for that print.
Yes, I have an older 8 bit control board which is running at a low baud rate, so those may also affect the data transfer rate.

Please do not mix old 8 bit boards with 2.4.S4, as this one has hc32 mcu. Anyway, I can confirm, that the print quality is quite bad with Octoprint on 2.4.S4 while the same gcode file can be printed in excellent quality directly from the sd card of the printer. With Octoprint the printing stopped many times for seconds causing the mentioned blobes.

What is your baud rate set at?
What does the resend ratio show? If that is more than a few per several thousand it may easily be a bad cable.

The fact that it prints well from the sd card but pauses and ruins the print from octoprint indicates a possible communication error, which can be a result of a bad usb cable or an incorrect baud rate for communications.

With 3d printers it is critical that there is clean communication between the printer and octoprint. I use about a 12 inch cable that is shielded and has a ferrite bead on the cable. To date my resend ratio has remained at '0' (zero) for many many prints, and some quite long.

Shielded cables are commonly better than unshielded cables, particularly for those printers that are known to have EMI interference problems such as the CR-10.

Baud rate is set to AUTO, so it's 115.2k. Cable length is around 50cm (20"), it's a new one, but unshielded. As far as I remember resend ratio was 0, but to be honest I didn't check it. I will print something with Octoprint to check the resend ratio.

I have tried 2 cables. I also have a setup with klipper tested the same cables and in this setup works fine.

I also tried two different cables and checked the resend rate. It was around 50/12k with both cables. When printer stopped for a while resend counter increased. It seems to be rather a sw fault, buffering issue, etc. than EMI problem.

This indicates failure of communications. Whether that is fault of the printer controller, PC, or usb cable has to be identified, but definitely a communication problem. Octoprint is unable to get response from the printer and repeatedly resends the data.

Were you able to figure anything out? I just installed OctoPrint with my Raspberry Pi 3 A+ and did the tape mod to the usb cable so the Pi isn’t back feeding power to the Ender 2 Pro mainboard.

I’m having the same issue it seems and it’s wrecking the prints. I have just stopped using OctoPrint and just using the SD card again. Can’t figure it out…. I have the same mainboard as you too.

OctoPrint works flawless on my Ender 3 Pro and that’s older using a 4.2.2 board. It was working so good I decided to just fully upgrade to Klipper and use mainsail with moonraker.

I have a feeling it’s this mainboard causing issues. Even Mihai Designs has the same issue.

No solutions with standard firmware.

The weird thing is that with klipper is working fine and I have no communications issues. So maybe is a firmware (creality) problem not a hardware? Idk

1 Like

Yeah I was considering converting to Klipper with this Ender 2 Pro, did you have any issues with the install being it has the 2.4.s4 board? Were you able to find a configure file to flash to the printer ok? Looks like OctoPrint is off the table with the stock firmware then and I'll just use OctoEverywhere with Klipper.

I used this bin and cfg link

This was my first klipper install and was a bit of a struggle.

In theory you can use octoprint with this workaround but I didn’t succed with the octoprint part. I am using fluidd now

I also tried data-only usb cable, but the result was the same.

Can you connect the printer to a PC running Pronterface?

Sure. Next time I will check it.

Flashed Klipper instead of the stock firmware. Resend rate is zero now.


Sounds like I’ll be going the Klipper route for this printer too then, so no more pausing during prints?