Ender 3 Error: Printer halted. kill() called!

What is the problem?

Printer will fail on the 3rd BLTouch Probing and disconnect. A mesage appears

Error reported by printer
Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: STOP called because of BLTouch error - restart with M999

What did you already try to solve it?

I have tried a few things like unplugging and replugging in the bltouch but it doesnt happen all the time so hard to figure it out.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.93 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 918192128
env.os.bits: 32
env.os.id: linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.15.1
env.plugins.pi_support.throttle_state: 0x50000
env.python.pip: 9.0.3
env.python.version: 2.7.13
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3
printer.firmware: Marlin bugfix-1.1.x (Github)

octoprint (2).log (43.4 KB)


there's nothing OctoPrint can do about it besides you can enter M999 in the terminal.
BlTouch has a self test at start and if it fails then there is a problem with the probe.

Sometimes it helps to cautiously wank the pin in/out a few times

Since it happens while bed leveling there are two options:

  1. There is either a mechanical or electrical problem and the probe doesn't deploy / stow as it should. Just watch it and check if that's the case.

  2. Your bed and/or the X axis is extremely crooked.
    When the probe finds a point that is 2mm lower (the 2mm depends on the printers config - could also be 1mm) than the middle of the bed the firmware stops the printer to prevent any crashes.

  • Here some solutions for 2. - if 1. is your problem we will figure out what to do when you tell me what happened.
    First check the X axis - for some reason Creality doesn't tell the users how to align it.

    If it looks like this - we found your problem.
    A lot of people on the internet will tell you to loosen the wheels in order to align it, but I don't agree with that method.
    Here is how I do it:
    First remove the cable from the Z stepper - it will be turned a lot and we don't want to damage your mainboard with the voltage it generates when it is getting turned.
    Then remove the top bar of the printer, remove the X axis and loosen this two screws

    Lower or raise the right end of the axis until you think it should be even.
    Fasten the screws again, put the X axis and the top bar in again and check the alignment.
    In the first picture it is getting measured against the top - that's one way - personally I measure against the left and right foot.
    I know it will take a few tries, but it's worth it.
    Remember to put the Z stepper cable back in when you're done.

Now roughly level your bed:
Lower the nozzle onto on corner of the bed and level it with the help of a piece of paper.
Keep the nozzle at that height and repeat it for the other corners. Just eyeball it - you can do a precise leveling when the BL-Touch is working.

Hope that helps :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.