Ender 3 pro usb problem

Hi,
I’ve got some problem with my ender 3 pro to be detected by a raspberry sometimes

My setup:
Ender 3 pro
Stock motherboard
Plugged via usb to a raspberry with octopi.
Both raspberry and ender 3 pro plugged to a power strip that is plugged to the wall to a smart socket.
Ender 3 and raspberry are always on, I just switch off the smart socket.

Now my problem:
Every time I reboot or power off the raspberry and/or the ender 3,
the raspberry don’t see anything plug to its USB port. ( I checked via putty lsusb command don't have the printer)
If I unplug everything for one hour (power cord remove from both) Still nothing.
If I let it unplug overnight, in the morning everything runs fine, the printer is detected and i can print for several days without problems
if i plug the printer on windows 10 i get an error with : unknown usb device : device descriptor request failed (I install octoprint on my windows and i've got the same problem)

I noticed that if I switch off the ender 3 with the raspberry plug in usb, the ender 3 is powered enough for the LCD. same via pc

What I tried:

Change the raspberry power supply
Change the usb cable
Change the raspberry
Change the raspberry sdcard with clean version of octopi.
Octoprint on windows
octoprint in safe mode
Tape on 5v usb plug to prevent the raspberry to power the ender 3.

I wanted to upgrade the firmware but with those usb issues , I’m a little worried to brick it.
When the usb is detected , I run 15Hours print without any issue via octoprint

I suspect an electronic issue (power leak ?) in my motherboard, but i'm not sure how to detect it or to fix it.

any help would be much appreciated.

here is the log of a fresh install:
octoprint.log (61.2 KB) serial.log (752 Bytes)

Hello @miqualke!

As from the error message, have you tried to set the serial parameters manually?
E.g.the baudrate to 250000?

What you see is the logic part of the Ender, not the whole printer. I must be powered with it's own power.

For Windows, you commonly need an appropriate USB driver.

It is usually set to 115200 and i can't set serial port it's always on auto

I understand that, i never tried to use the printer with only usb power

When my usb port work, i can control the printer from cura

thanks for your help

I don't know if it's clear in my post that it seems that after i used it, the usb port of the ender 3 motherboard need time to "cool off" several hours before it will work again.