Ender-3 S1 Pro is not preheating bed or nozzle before a print statrs

What is the problem?

I am new to Octoprint, and 3D printing in general. That being said, I quickly realized the stock Creality firmware is crap (and didn't fully support Octoprint) and am now running TH3D's Marlin 2.0 firmware. I finished setting everything up (Including copying the starting/ending gcode directly from Creality's slicer into Octoprint) and went to start my first print. To my dismay, the printer did not preheat the bed or nozzle, and immediately started printing. Obviously, this probably isn't going to work. I have a feeling I missed something important in the setup, but I'm apparently being dense and can't find any help through Google.

What did you already try to solve it?

Verified the start/end GCode is the same as what the slicers user. Tried re-slicing my model and restarting a print.

Have you tried running in safe mode?

No, would this potentially fix the issue?

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20220628233040.zip (209.9 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octo-Pi Platform

Octoprint 1.8.1
OctoPi 0.18.0
RaspberryPi B 3


Ender-3 S1 Pro
Latest TH3D Firmware for Ender-3 S1 Pro


I think this is the problem. You don't need to duplicate the gcode from the slicer into OctoPrint, otherwise it is applied twice. If this gcode has placeholders in it for the temperatures (often configured in the slicer settings), these will be invalid in OctoPrint and so the temperatures may not be set. In the serial log, it is showing sending the start gcode, but yeah there's no heating commands before the extrusion attempts.

What is the contents of the start gcode in both OctoPrint & the slicer?

Ahh, interesting. Here's the gcode I pulled from the slicer software:


G28 ;Home

G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up


G91 ;Relative positionning
G1 E-2 F2700 ;Retract a bit
G1 E-2 Z0.2 F2400 ;Retract and raise Z
G1 X5 Y5 F3000 ;Wipe out
G1 Z10 ;Raise Z more
G90 ;Absolute positionning

G1 X0 Y0 ;Present print
M106 S0 ;Turn-off fan
M104 S0 ;Turn-off hotend
M140 S0 ;Turn-off bed

M84 X Y E ;Disable all steppers but Z

You were 100% right. I pulled the start and stop code out of Octoprint and the bed and nozzle is heating correctly. Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.