Ender 3 SerialException Issues

What is the problem?

Unfortunately I'm getting random SerialException issues with my Ender 3 (4.2.2 board) which strike very often.

I'm starting to run out of ideas, and beginning to come around to the idea of going back to using the SD card :pensive:

I've put down any info I can think of, but please do let me know if there's anything missing.

What did you already try to solve it?

  • Tried a couple of USB cables, I'm about to try a 3rd (or 4th - losing track!). If there's any recommendations for known good USB cables available in the UK, please let me know!
  • Attached some of these ferrite cores to both Pi power and printer USB cables
  • Tried a Pi 3 and a Pi 4
  • Used different power adapters for the Raspberry Pi's, I'm not getting any throttle or power warnings
  • Moved the Pi/s outside of the enclosure, but still with short USB cables going to printer
  • Turned off LED lights inside enclosure in case of interferance
  • Moved LCD cables as per this suggestion
  • Taped over USB power pin
  • Turned off LED strip inside enclosure, on the off chance it might help reduce interference

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

  • OctoPrint version: Version 1.6.1
  • OctoPi Version 0.17.0, running on Raspberry Pi 3 Model B Rev 1.2
  • Printer Ender 3 (with 4.2.2 board)
  • Using a BLTouch for bed leveling
  • No extra USB peripherals are attached to the Raspberry Pi, but there is one of the raspberry pi ribbon cameras attached
  • Firmware: Marlin
  • Octoprint log
  • Serial Log

hi :slight_smile:

Try it again with and without an inserted sd card.
Some creality boards got sd card related issues and maybe you got one of them

Ah that sounds like a good idea, I've just plugged in the printer and pi to a different power socket. If I get more errors after that, I'll give this a try

See my response in https://community.octoprint.org/t/ender-3v2-disconnecting-at-random-times/36720/2.

1 Like