Ender 3 V2 - Doesn't stop for filament change

What is the problem?

I am using Cura Slicer 4.8 to insert Post G-Code processing to add a Filament change code (M600) to my code. I have tried this 3 times now and the printer never stops when going through octoprint. Same code directly on an SD card to printer and the printer stops.

What did you already try to solve it?

Firmware upgrade to latest marlin
tried onboard instead of octoprint

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Version 1.5.3 of Octoprint. Running on Latest Octopi Version. Ender 3 V2.

Those are logs. Now show us yours.

3 Likes

octoprint.log (29.3 KB)

lol nice pic, i uploaded logs, but i didnt see anything that wouldve caused this there.

Do you have HOST_PROMPT_SUPPORT and HOST_ACTION_COMMANDS enabled in the firmware?

These are needed for the printer to tell OctoPrint that it is doing a filament change, and OctoPrint will stop sending commands to the printer.

If you are using the stock Creality firmware, then it does not support this. You could try and enter @pause in the gcode, which will signal to OctoPrint it should pause. You can then go to town with the pause and resume scripts.

I did not,

i went ahead and compiled new firmware to add both of those. I then sliced a calibration cube with a M600 at layer 4.

no change.

What about if you just send M600 to the printer in the terminal? Enable serial.log, reproduce the issue and then upload the serial.log.

I guess to state the obvious, you do have M600 (advanced pause) enabled?

So about how i didnt have M600 enabled in the firmware.... Thanks Charlie!

Enabled, Recompiled, flashed. Now i can swap filaments, though the process seems a bit clunky.

Printer beeps for about 10 seconds but starts to cool down. Does a retraction atleast so the filament can easily be pulled out.

inserted new filament and clicked ok. Then reheats, then i have to hit ok after reheat

then it extrudes a bit and continues.

weird part is 1st test it extruded probably about 100mm of filament and 2nd it only did a small amount.

Nothing ever shows up on the LCD either.

Seems clunky