Ender 3 V2 no detected by octoprint

What is the problem?

My problem is that my ender 3 V2 printer is not connecting to octoprint and it gives me the error message:

State: Offline after error
No more candidates to test, and no working port / baudrate combination detected.

What did you already try to fix it?

Test various usb cables from different devices

Logs

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port / baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error"
Changing monitoring state from "Error" to "Offline after error"

Additional information

When performing an LSUSB, the system detects the printer with one of the usb but octoprint does not

Additional information about your configuration

OctoPrint v1.7.2
Open media vault
Ender 3 V2
4.2.2 Creality motherboard

The printer is probably drawing too much power via usb.

Log into your pi via ssh then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

hello @PrintedWeezl

post the output to dmesg | tail -n 20 and lsusb
Captura

The QinHeng Electronics think is Ender 3 V2
lsusb

It's definitely detected and should be reachable under ttyUSB0.

Try this plugin

Nothing, still not connecting, I have installed the add-on but still not making the connection

Wait a second - I just noticed the lsusb output.
I thought you're using a Pi with an Octopi image.

Did you add the Octoprint user to the tty and dialout group?

sudo usermod -a -G tty <username>
sudo usermod -a -G dialout <username>

Yes, I just added the two lines and I have restarted octoprint and the server but it still does not connect

I am using a laptop with openmediavault and docker, I have listed the users of the system and I have added all the ones that I thought could be and nothing

specifically root, admin and openmediavault-webgui

How have you installed OctoPrint? Using the official docker container or something else?

Ok but which user using is running the Octoprint server? It might be none of those users.
How did you install it?

i am using this container

https://hub.docker.com/r/octoprint/octoprint#octoprint-docker

lo instalé utilizando portainer.io con el docker-compose

make sure you got

     devices:
      - /dev/ttyUSB0:/dev/ttyUSB0

in the docker-compose.yml

Check out this example if you need help with the file

OMG I forgot to uncomment the line of devices ...

Thank you very much for the help, I will try to be more careful next time XD

1 Like