Ender 3 V2 Not Detected By OctoPrint

What is the problem?

OctoPrint doesn't detect the printer.

What did you already try to solve it?

This is a first time, fresh setup of OctoPi, and I'm a completely new user. The only solution I've been able to find for this issue is "try another USB cable", so I've tried somewhere around ten, and I'm fairly certain they aren't all power only. I don't readily have any other microUSB B devices that I can test them with to see if they make a connection, but I doubt I have that many broken cables lying around. I can go out and buy another one, but I'd hate to do that and have it be a waste of time and money. I've updated the OS, as well as updated OctoPrint through the web interface. Is there anything else I can try? Something I can check? Is there some known issue I'm not finding?

Have you tried running in safe mode?

Yes.

Did running in safe mode solve the problem?

No.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port/baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."
Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version: 1.5.2
OctoPi version: 0.18.0
Printer: Creality Ender 3 V2 w/ 4.2.2 mainboard
Firmware: Marlin bugfix 2.0.x
Hardware: Raspberry Pi 3 B Plus
Browser: Brave
OS: Windows 10

Try plugging the printer in to another port on the Pi, try plugging it into another PC/laptop or similar to see if it is recognised as a device. There's 3 things that could be the issue - the Pi and it's USB ports, the cable, or the printers USB port.

9 times out of 10 it is the cable, that's why you've found that. We've even had people say that the cables all worked with other devices but only some with their Creality printers.

The other thing you can try for USB debugging is the following:

Run an lsusb command, copy the output, inplug and re-plug the printer and run again - see if there is a change in the list of devices.

Second, unplug and re plug the printer and run dmesg | tail -n 20. This will report if there are any errors establishing a connection with the printer.

Thank you for the incredibly fast response, I appreciate the help. I tried lsusb and there was no change in the list, and the other command wasn't giving me any errors. So I remembered that my newish headphones use a microUSB b, and that's the newest cable I have, so I pulled it out of my PC to try on the printer and of course it worked. Are 3D Printers just absurdly picky about USB cables? I can head down to MicroCenter and buy a new cable, but who's to say it'll work if it's this finicky? Am I now resigned to buying and returning cables until I find one that works? Sorry, I think I'm just complaining out-loud at this point. I really do appreciate your assistance and will mark this thread as solved.

Many of them seem to be - and it's heavily weighted towards Creality. We have backpowering issues, temperature reporting issues, SD card issues. The hardware is built cheap, so this is what you end up with. Most high quality cables do work, though I don't know definitely because they're not the kind of thing you keep buying once you have some that work.

Yeah, hopefully the first one I buy will work. I think I'll try a Startech.com cable I found on Amazon. Says it's data, so we'll see! Thanks again for all your help.

1 Like

Features of a USB cable for a Creality product are:

  1. Short as possible
  2. Shielded
  3. Ferite core(s)

Here's one I think would be suitable, https://www.amazon.com/Monoprice-6-Feet-Ferrite-Plated-105458/dp/B003L18S0E. Note it is available in 1.5 and 3 feet as well.

In 99% of the installations, putting tape over the +5V pin at the A end of the cable will be needed.

Additional shielding or rearranging of the internal cabling of the printer may also be necessary.

Just wanted to let you know that I installed OctoPrint and initially was able to connect to my Ender 3 V2 but then it stopped connecting to the printer for no apparent reason. I was able to solve this issue by manually setting the baudrate from AUTO to 115200. I have restarted OctoPrint and my machine multiple times and it consistently connects to my printer now. I hope this helps anyone else looking for a solution to this connectivity issue.

I'm currently using the stock firmware version 1.0.2 from Creality.

Wow, that's horrifyingly bad, and pathetic on Creality's part. I actually purchased this item, https://www.amazon.com/StarTech-com-30cm-Micro-USB-Cable/dp/B003YKX6W2?ref_=ast_sto_dp&th=1 and it works great, at least so far, and as far as I can tell. Thank you for the reply and suggestion, though!

Trying here before I just completely give up. I've been scrubbing these forums (and Reddit) since late 2020 trying to get my Ender 3 v2 connected to my OctoPi with no avail. I've scrubbed through every single forum entry I can find and just can't get this to work. Things I've tried:

  • New cables - Probably have gone through about 10. Even purchased the one here that @Zachariel said was working for them.
  • Different USB ports
  • Connected directly to PC - nothing detected, no recognition in Pronterface
  • Firmware upgrades/downgrades
  • Taking a walk

I'm running a 4.2.2 mobo with v1.6.1 OctoPrint. Any guidance would be super helpful, even just a link to a forum/video you think I may have missed. Otherwise I'm pretty darn close calling it quits.

If your printer isn't even recognized when you connect it to your PC, then this sadly sounds like your board's USB connection might simply be fried. In which case no amount of cables or software fix attempts will solve it, only swapping the board will.

Thanks for the quick reply. This makes the most sense to me, too. I'll reach out to Creality and see if they'd replace it since I bought it back in Dec.

In future, don't suffer in silence! The community forums are made for people to post as well as read and search. While we might get annoyed if there's thousands of posts on the same topic, if you've made an effort to solve it yourself then ask for help and usually it comes. Here or on the discord server.

4 Likes

Thanks so much @Charlie_Powell! I consider myself a pretty good creative problem solver but this one has just got me stumped. I bought a brand new V4.2.7 Motherboard, swapped it out and I'm still having the same issues. I'm currently using the 6in Right Angle version of this USB cable. I may try to find y'alls Discord and see if anyone is willing to do a call with me. More fun facts about my setup:

  • Octopi used to be fully functional a few years ago when hooked up to the office Flashforge and then Prusa
  • I've tried all 4 USB ports and no connection success
  • I can access camera feed but no printer data

Creality products are very sensitive to RFI/EMI often generated by the product itself. A really good USB data cable is often the solution. I use https://www.amazon.com/gp/product/B008VOPCGY which is shielded and has ferite cores.

You may have to experiment with routing the USB cable differently as well as the routing of other cables inside the printer. This forum is full of "not detected" and "communication failures" with Creality printers. Many solutions have been posted as well and one of them will probably solve your problems.

So I jumped into the Discord and @SwHawk immediately helped me out. @TTalkington deduced that was issue was a historical GPX plugin that was no longer necessary messing with my connection on my Ender 3 v2. I disabled it and was able to connect. Huge thanks to this community!

1 Like

how do i disable GPX ?

Hello @tanmay_warokar !

Go to OctoPrint Settings -> Pluginmanager -> search for GPX plugin -> disable or delete it.