Ender 3 v2 / Printer halted. kill() called

What is the problem?

After heating the bed and the extruder to the desired temperatures, the printer sends "Printer halted. kill() called".

After that I cannot select anything on the screen anymore as well, completely hangs.

What did you already try to solve it?

  1. Installed both creality temp fix plugins
  2. taped off the 5v connector on the usb cable.
  3. tried with and without the SD card in the printer.

Have you tried running in safe mode?

No effect

Did running in safe mode solve the problem?


Complete Logs

serial.log (51.9 KB)

Additional information about your setup

Octoprint v1.5.3
Ender 3 v2 firmware level: 1.0.1

I use a Raspberry pi 4GB model to run octoprint.
I'm at my wits-end at the moment as to what could be the problem.

Anyone have any hints for me?

Hello @make_build !

So here:

2021-03-14 12:35:18,554 - Recv:   TT::209.34209.34  //210.00210.00  BB::65.0065.00  //65.0065.00  @@::3535  BB@@::4545

For the first time reaches 209°C


2021-03-14 12:35:36,554 - Recv:   TT::209.41209.41  //210.00210.00  BB::65.0065.00  //65.0065.00  @@::8484  BB@@::3939

it is still 209°C - since about 18 seconds.

But it does not reach 210°C. This is the error. It does not get warmer. In other words: thermal runaway protection.

Either the printer power supply is not sufficient, the heater cartridge is not firm enough in the hotend block or the thermistor got lose.

Hi Ewald!

Thanks for looking for me.

When I use the sneaker-net version (Files on a SD) the printer prints fine? It's just with Octo print that it cancels after getting close the goal temp.

The problem is, you are using Creality's firmware. We just don't know what they change that makes it break printing from USB sometimes.

If you have an SD card in the printer, take it out (or put it back in). Unbelievable, but has caused these kinds of issues before.

Also, for you it could be an intermittent issues with wiring. It is still worth checking every connection is still solid.

Your firmware made me check the version, and it seems that an older version had a higher version number then a later one.... Go figure...

So I tried the 1.0.2 version: everything works.