Ender 3 v2 upgraded mainboard to 4.2.7 Octopi not working

My Ender 3 v2 has been working fine with octopi, i decided to upgrade the mainboard to 4.2.7 now i am not able to connect to octopi. I am getting the following error -

State: Offline after error
No more candidates to test, and no working port/baudrate combination detected.

WRITE HERE

What did you already try to solve it?

WRITE HERE

Have you tried running in safe mode?

Tried rebooting the Ender 3 v2 and the Raspberry Pi multiple times, Checked cables and connections

Did running in safe mode solve the problem?

Tried safe mode same issue

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

Octopi version 1.6.1
Raspberry Pi 4 2GB
Ender 3 v2
Old Mainboard ver 4.2.2
New Mainboard ver 4.2.7

Is there anything else i need to do after changing the mainboard which could be cuasing this?

It's not going to be possible for anyone here to do anything but take guesses without the logs and information that you were asked to provide in the template.

Also, there's very little difference between the 4.2.2 board that comes with the v2 and the 4.2.7 board. The MCU itself is wired slightly differently and the stepper drivers may be a different version, but it's essentially the same board otherwise. The fact that it worked before and doesn't now doesn't really mean anything in itself.

2 Likes

Have you loaded the Creality firmware or another build onto the new board. Potentially there maybe a serial baudrate difference. Typically only 250000 or 115200 are used .