Ender 5 Plus Octoprint Z offset not working properly

What is the problem?

Octoprint does not follow Z offset from board. It will either start at a random height or decide to cut a groove into the glass bed. I have tried to manually offset this before, after and during prints and the results are always the same.... Printing from printer interface, no problem, Printing from Octoprint through serial, it does not collect the Z offset and begins on its merry way either slamming into the glass or printing a few mm above which is entirely useless.

What did you already try to solve it?

Googling, Praying to gods, Scouring youtube of content creators who explain absolutley nothing. ive got a level bed, please dont suggest "leveling my bed"

Have you tried running in safe mode?

I dont think there is a safemode for this....

Did running in safe mode solve the problem?

No

Additional information about your setup

I am using an Ender 5 plus. The only upgrades ive made are swapping out the springs to the silicont stubs (it does work better), extruder mechanism has been changed from plastic to metal so it actually outputs material instead of clicking... and the nozzel has been switched to 0.6 both in software and reality. I am in need of genuine help here, im out of my depth at trying to figure this out.

Hello @Chris !

You know how safe mode works with OctoPrint?

Nope. is it like "im not going to slam into the glass bed and cut a 0.3mm groove into the bed" Mode?

There is a "I'm not passive aggressive when somebody tries to help me" mode in this forum and it's always enabled!

1 Like

So how do you know?

Safe mode in OctoPrint deactivates all 3rd party plugins.

If the printer works well then, one of the plugins is the culprit.

And please, share the systeminfo bundle!

sorry, it happend like 10 min ago on the brand new bed i put on so i feel a bit salty about that happening.

Yeah I get that. That unfortunately happened to a lot of us for different reasons.

The only 3rd party plugin i have is Octolapse.

octoprint-systeminfo-20220927121048.zip (36.6 KB)

... and Bed Visualizer, Camera Settings and Themeify.

There is the error message from the printer:

2022-09-27 11:09:43,316 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: STOP called because of BLTouch error - restart with M999
| Last lines in terminal:
| Recv: echo:  M200 D0
| Recv: echo:Steps per unit:
| Recv: echo:  M92 X80.00 Y80.00 Z800.00 E93.00
| Recv: echo:Maximum feedrates (units/s):
| Recv: echo:  M203 X500.00 Y500.00 Z10.00 E50.00
| Recv: echo:Maximum Acceleration (units/s2):
| Recv: echo:  M201 X500 Y500 Z100 E5000
| Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
| Recv: echo:  M204 P500.00 R1000.00 T500.00
| Recv: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
| Recv: echo:  M205 S0.00 T0.00 B20000 X8.00 Y8.00 Z0.40 E5.00
| Recv: echo:Home offset:
| Recv: echo:  M206 X0.00 Y0.00 Z0.00
| Recv: echo:Auto Bed Leveling:
| Recv: echo:  M420 S0 Z2.00
| Recv: echo:PID settings:
| Recv: echo:  M301 P14.72 I0.89 D61.22
| Recv: echo:Z-Probe Offset (mm):
| Recv: echo:  M851 Z-2.49
| Recv: Error:STOP called because of BLTouch error - restart with M999

You may have to realign the BLtouch with the new bed. There should be a menu point in the printer's firmware.

This was it touching the frame instead of the buildplate. The generic issue with the ender 5 plus putting the home location in the back left instead of the centre of the bed. I restarted after this.

Do you suggest restarting it over again to see if this happens again?

Does the bead has the same dimension as the old one?