Ender 5 Pro, Octoprint & PS3 Eye

PS3 Eye

I purchased a raspberry pi 3B with a PS3 eye camera. The camera connects, and after approx 30seconds - 1 minute it freezes.

I have tried to change the configuration settings in octipi.txt for the camera settings. I have changed pretty much everything in there, and tried all different combinations. I've done some searching online, and i'm not entirely sure if the PS3 eye camera that ive purchased is the best match for the raspberry pi 3b.

Any other suggestions on why it could be freezing? Do we think it's the camera being faulty, or the settings i've chosen. Not really sure what i'm doing beyond this point

octoprint log.log (606.5 KB)

Octoprint Version 1.4.2

Hello @Matthew_Russ!

First: We strongly recommend not to pull the power plug from the Pi to restart it. Sooner or later you will have a damaged filesystem on the Pi's SD card.

Second: It seems you need to install this plugin:

Third: It seems you have a unstable connection to your printer:

2020-11-21 15:30:23,844 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 18, current line = 21
| Last lines in terminal:
| Recv: ok
| Send: N15 G1 Z2.0 F3000*47
| Recv: echo:Unknown command: "ÿ><ï.øóÿ­$šáýÿÿÿþß:	"
| Recv: ok
| Recv: echo:Unknown command: "1ã3"
| Recv: ok
| Send: N16 G1 X10.1 Y20 Z0.28 F5000.0*17
| Recv: echo:Unknown command: "k"
| Recv: ok
| Send: N17 G1 X10.1 Y200.0 Z0.28 F1500.0 E15*94
| Recv: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
| Recv: ok
| Recv: ok
| Send: N18 G1 X10.4 Y200.0 Z0.28 F5000.0*52
| Recv: ok
| Send: N19 G1 X10.4 Y20 Z0.28 F1500.0 E30*124
| Recv: ok
| Send: N20 G92 E0*117
| Recv: Error:Line Number is not Last Line Number+1, Last Line: 17
| Recv: Resend: 18

This can be the cause. Do you have the chance to test it on a PS3?

Thank you so much for your quick reply.

Very new to all this, and very inexperienced. How would you suggest I disconnect the pi and turn the power off?

Regarding the connection, could this be wifi related? The pi is fairly far from my router - maybe I need to have a switch around

Thanks again, really appreciate it

In the UI under 'system' in the navbar, you can shutdown.

You could also try installing the WiFi status plugin, so you can see what the signal strength is.

1 Like