Ender3 V2 losing serial connection on longer prints

What is the problem?

I have been running into issues with my OctoPrint losing connection to my Ender 3 V2 on longer prints. I have installed the official image on a Raspberry Pi 4 2gb and did the 1.6rc update yesterday which may be when the issue popped up. I don't remember if I did longer prints before. I am running the Ender3 V2-4.2.2 Marlin-2.0.1-BL-Touch – V1.1.1(without adapter board) firmware from creality3dofficial.com. I managed to do a few smaller prints around 1-1.5 hours fine, but just loaded a 2.5 hour print and it crashed about half way with " Communication error

There was a communication error while talking to your printer. Please consult the terminal output and octoprint.log for details. Error: Too many consecutive timeouts, printer still connected and alive?"

What did you already try to solve it?

I have tried changing which usb ports I am using on the raspberry pi, testing smaller prints which seem to be fine. I have not swapped the cable out yet as I would expect a faulty cable to effect on smaller prints as well.

Have you tried running in safe mode?

I have not.

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20210428233405.zip (3.2 MB)
octoprint-logs.zip (963.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I tend to bounce between my phone and Chrome on Windows 10 to watch the prints. The only Plugins I have on other than stock is Z Probe Offset and Creality-2x-temperature-reporting-fix (0.0.4)

Some additional notes on this. it seems like a timeout on the usb. I loaded the files direct to the SD case and it ran fine. I tried loading a 16mb file to the sd card and after 45ish min the printer disconnected.

Communication timeouts usually point towards firmware bugs. What it means, if you don't know is that OctoPrint was connected to the hardware over USB, but it never received a response, usually pointing to something crashing somewhere.

Given the number of issues we see with Creality's firmware (eg. here, here, here, here, here) I would probably recommend trying a vanilla Marlin build without Creality's added bugs.

There's examples for your printer available in this repository:

And lots of videos on YouTube etc. to show you how to compile and upload the firmware (for example, this TeachingTech one I found useful.

Hi, did You manage to find solution? I have the same situation. I use Marlin and OctoPrint on Raspberry Pi 4 Model B Rev 1.2. When I print larger thins I get Communication error. Just today after 12 hours print I had this issue. My octoprint.log (339.4 KB) and also terminal.log (7.9 KB) .

I haven't had much time to try updating. I have had a few 4-5 hour prints work fine, but then I was printing a 3 hour print and it failed 20 min in. I am just having a bad time with my tech right now lol

I think it is more or less random - I had one after just 1-2 hours, one after 19 hours and today after 12 hours. I think I will switch to print from SD for now. Pitty as OctoPrint functionality is just great.

I just experienced connection issues with my printer today and of course I was thinking about the cables, because I swapped the filament. I tried to reposition the cables, swap the USB-cable - nothing worked.

After all it was the filament dryer that I had running close to my printer. After I switched it off, everything was working fine. I also re-created the problem by switching on the filament-dryer while I started a print. It took a couple of seconds and the printer was losing the connection again and restarting.

Silly thing, because I thought EMC was a problem in industrial appliances, not home appliances.

1 Like

EMC is an issue everywhere.

Ask the Ham radio operators and short wave listeners.

It is, I have this problem (communication timeout) when using a USB cable with the 5V line disconnected (the main board should in my opinion not reference the raspberry pi 5V.)

Only seems to happen in the dead of night on prints longer than 4 or 5 hours.