Ender3 won't power on with 5V taped. Powers on but with TMC Connection Error if 5V not taped. Suspect relay failure?

What is the problem?

My Ender 3 has been in storage and I recently decided to set it up again. It was running perfectly before. I reinstalled Octoprint but it failed to make serial connection automatically: "Offline after error". Tried a different USB cable without the 5V pin taped but the printer showed "TMC Connection Error", which was the reason why the 5V pin had to be taped in the first place.

After going back to the taped cable and powering the printer on, I noticed a weird behavior. Usually at power on, the BLTouch would cycle by itself 3 times while the LCD screen displays the bootup screen. Now, the BLTouch would cycle once while the LCD screen turns on without the bootup screen, then the entire printer would turn off suddenly. I suspect the relay the Pi is using to control the PSU is switched off in the middle of start up. Safe mode did not solve the issue. See video links below.

Bootup showing screen

Bootup relay closeup

Anything you recommend I try before attempting the following:

  • replace relay
  • reflash firmware
  • replace motherboard

What did you already try to solve it?

Safe mode, different USB cable with/without 5v taped.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 1908686848
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.9.3-20231009151442
env.plugins.pi_support.octopiuptodate_build_short: 2023.10.09.151442
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.3
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.last_safe_mode.date: 2023-11-17T05:33:39Z
octoprint.last_safe_mode.reason: incomplete_startup
octoprint.safe_mode: True
octoprint.version: 1.9.3
systeminfo.generated: 2023-11-20T04:16:16Z
systeminfo.generator: zipapi

Additional information about your setup

What kind of hardware precisely, OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

  • Raspberry Pi 4
  • Octopi 1.0.0 & OctoPrint 1.9.3
  • BIGTREETECH SKR Mini E3 V2.0 TMC2209
  • Brave browser
  • Win11

You can bypass the relay to prove your relay suspicions.

If it powers up and stays up. You were right. Then you can know you are chasing the right issue.

1 Like