Erro: Device reports readiness to read but returned no data

What is the problem?

Hello,I am a Octopi noob. I stopped 3D Printing for 9 months and when I came back I try to sett up everything again. Everything ran flawlessly with octopi in the past. Now when I try to print something with octopi I got the error message "SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)" then the print Stops.

I have no clue about octopi when I was setting up octopi in the past everything worked.

What did you already try to solve it?

I Updated octopi to the current firmware
Restarted my Wi-Fi
Tested it with the Raspberry Pi camera and without
Used different USB Ports

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (131.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @Bertling31 !

It seems you have a very unreliable USB connection to the printer:

2023-01-06 01:06:45,908 - octoprint.util.comm - WARNING - Received line:
2023-01-06 01:06:45,909 - octoprint.util.comm - WARNING - | M‰‹ý•$‰£€•–"Ñ 2EdDDâЛff¶âÒ)z€@TZ–X¶ø0›†U	[‘„Ë!¦*@M%Ò5:¡ºe6,Ð-Z"À"Dý$"FÀ"BоÉÛPÉj %h¾€¢@"ÐF "Død$KSæ@ՙëa·¥BùKÐ" þDZ±k™ë—Àd›¯@LbB#:¦
˃2þ"DDD]D""%D¨ºðáUKdÐ^dDDMD"DZP¶B²Ù̀$K2$KS+Ó Ò2II•#‚¿"8 \x00K?"ø  ^˦UZR"DAEø¨>\x00‹#DIEø‘Dª>¢ºeËëKè’	•%É?Z"H˺ƒÖüKÐ
“Ëecho:Unknown command: ""

You may have a look on this:

BTW: What printer do you use?


Pulling the plug from the Pi to reset dos not make it better, it gets even worse.


Thank you for your help!

I am using an anycubic Mega X

I read this post with the Ender 3 but now I got some more questions, If understood it correct but I am not sure, The "Printer Cable" causes this sort of problems. But I don't know which cable he means with Printer cable, the Power Plug, The USB to RPi or something else.

What kind of plug do you mean with pulling the plug? Yeah i am noob I pull the plugs all the time to fix something lol


Usually this is the USB cable from the Pi to the printer.

I meant the power supply of the Pi.
The Pi is a small, but sophisticated computer and has to be shut down like a large one, else you can get in trouble with a corrupted file system on the SD card.

Oh thank you, from now on i will turn it off.

Do you have any suggestions how i can fix the problem with the USB Cable, i realy dont know what to do :frowning:

Recommended is a cable as short as possible, with ferrite beads and thick wires.

Such like this:

Thank you, i will test it and tell you in a few days

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.